summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-05-01 18:17:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-05-01 18:17:53 +0000
commit90dedca332c546d7db6e19a238a9a7e2695e547d (patch)
treef391f5a2b9ed5be455b9951a2b358e6330e1f5f8 /app-benchmarks
parentx86 stable wrt #266096 (diff)
downloadgentoo-2-90dedca332c546d7db6e19a238a9a7e2695e547d.tar.gz
gentoo-2-90dedca332c546d7db6e19a238a9a7e2695e547d.tar.bz2
gentoo-2-90dedca332c546d7db6e19a238a9a7e2695e547d.zip
Applying fixes from Tiago Cunha, #261720
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/stress/ChangeLog7
-rw-r--r--app-benchmarks/stress/stress-1.0.0.ebuild17
2 files changed, 16 insertions, 8 deletions
diff --git a/app-benchmarks/stress/ChangeLog b/app-benchmarks/stress/ChangeLog
index ed7519bd4b58..827291594e42 100644
--- a/app-benchmarks/stress/ChangeLog
+++ b/app-benchmarks/stress/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/stress
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.32 2009/04/24 04:56:49 darkside Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.33 2009/05/01 18:17:53 patrick Exp $
+
+ 01 May 2009; Patrick Lauer <patrick@gentoo.org> stress-1.0.0.ebuild:
+ Applying fixes from Tiago Cunha, #261720
24 Apr 2009; Jeremy Olexa <darkside@gentoo.org> stress-1.0.0.ebuild:
amd64 stable, remove an empty man page shipped by upstream. bug 261720
diff --git a/app-benchmarks/stress/stress-1.0.0.ebuild b/app-benchmarks/stress/stress-1.0.0.ebuild
index 0ff2e42f3b38..166e66f3018b 100644
--- a/app-benchmarks/stress/stress-1.0.0.ebuild
+++ b/app-benchmarks/stress/stress-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-1.0.0.ebuild,v 1.4 2009/04/24 04:56:49 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-1.0.0.ebuild,v 1.5 2009/05/01 18:17:53 patrick Exp $
inherit flag-o-matic
@@ -15,17 +15,22 @@ SLOT="0"
KEYWORDS="amd64 ~mips ppc ppc64 ~sparc ~x86"
IUSE="static"
-DEPEND="virtual/libc"
+DEPEND="sys-apps/help2man"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ # Force rebuild of the manpage
+ rm -f "${S}"/doc/stress.1
+}
src_compile() {
use static && append-ldflags -static
- econf || die "econf failed"
+ econf
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog AUTHORS README
- # Upstream ships an empty file...
- rm -r ${D}/usr/share/man
}