summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-02-01 21:50:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-02-01 21:50:49 +0000
commit502fab1a3a9ec2e8e694123802c57d3e61872826 (patch)
treea6ef9bb17e14ea64d70cdd459fdcc2bcc1d5c5c1 /app-benchmarks
parentBump EAPI thanks to scarabeus. (diff)
downloadgentoo-2-502fab1a3a9ec2e8e694123802c57d3e61872826.tar.gz
gentoo-2-502fab1a3a9ec2e8e694123802c57d3e61872826.tar.bz2
gentoo-2-502fab1a3a9ec2e8e694123802c57d3e61872826.zip
Add necessary curl USE flag depend on PHP. bug #352791. Add an EAPI=4 version to clean up depends.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/phoronix-test-suite/ChangeLog12
-rw-r--r--app-benchmarks/phoronix-test-suite/metadata.xml4
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1-r1.ebuild65
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1.ebuild6
4 files changed, 78 insertions, 9 deletions
diff --git a/app-benchmarks/phoronix-test-suite/ChangeLog b/app-benchmarks/phoronix-test-suite/ChangeLog
index b0a409e67b35..cc8b5f747381 100644
--- a/app-benchmarks/phoronix-test-suite/ChangeLog
+++ b/app-benchmarks/phoronix-test-suite/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-benchmarks/phoronix-test-suite
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/ChangeLog,v 1.11 2010/11/10 20:18:09 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/ChangeLog,v 1.12 2011/02/01 21:50:49 cardoe Exp $
+
+*phoronix-test-suite-2.8.1-r1 (01 Feb 2011)
+
+ 01 Feb 2011; Doug Goldstein <cardoe@gentoo.org>
+ phoronix-test-suite-2.8.1.ebuild, +phoronix-test-suite-2.8.1-r1.ebuild,
+ metadata.xml:
+ Add necessary curl USE flag depend on PHP. bug #352791. Add an EAPI=4 version
+ to clean up depends.
*phoronix-test-suite-2.8.1 (10 Nov 2010)
diff --git a/app-benchmarks/phoronix-test-suite/metadata.xml b/app-benchmarks/phoronix-test-suite/metadata.xml
index 98dd35ede900..4ae12df4e63c 100644
--- a/app-benchmarks/phoronix-test-suite/metadata.xml
+++ b/app-benchmarks/phoronix-test-suite/metadata.xml
@@ -3,10 +3,6 @@
<pkgmetadata>
<herd>benchmarks</herd>
<maintainer>
- <email>cardoe@gentoo.org</email>
- <name>Doug Goldstein</name>
- </maintainer>
- <maintainer>
<email>patrick@gentoo.org</email>
<name>Patrick Lauer</name>
</maintainer>
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1-r1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1-r1.ebuild
new file mode 100644
index 000000000000..f84b5c3a1b6f
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1-r1.ebuild,v 1.1 2011/02/01 21:50:49 cardoe Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
+HOMEPAGE="http://www.phoronix-test-suite.com"
+SRC_URI="http://www.phoronix-test-suite.com/download.php?file=${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+DEPEND=""
+
+# php 5.3 doesn't have pcre useflag anymore
+RDEPEND=">=dev-lang/php-5.2[cli,curl,gd,posix,pcntl,pcre(+),truetype]
+ app-arch/unzip
+ dev-php5/pecl-ps
+ gtk? ( dev-php5/php-gtk )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/font.patch
+ sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
+ phoronix-test-suite
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r {pts,pts-core}
+
+ doman documentation/man-pages/phoronix-test-suite.1
+ dodoc AUTHORS CHANGE-LOG
+ dohtml README.html
+
+ exeinto /usr/bin
+ doexe phoronix-test-suite
+
+ fperms a+x /usr/share/${PN}/pts/test-resources/*/*.sh
+ fperms a+x /usr/share/${PN}/pts/base-test-resources/*/*.sh
+ #fperms a+x /usr/share/${PN}/pts-core/modules/*.sh
+ fperms a+x /usr/share/${PN}/pts-core/test-libraries/*.sh
+ #fperms a+x /usr/share/${PN}/pts/distro-scripts/install-gentoo-packages.sh
+
+ # Need to fix the cli-php config for downloading to work. Very naughty!
+ dodir /etc/php/cli-php5
+ cp /etc/php/cli-php5/php.ini "${D}/etc/php/cli-php5/php.ini"
+ sed -e 's|^allow_url_fopen .*|allow_url_fopen = On|g' -i "${D}/etc/php/cli-php5/php.ini"
+
+}
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1.ebuild
index 3c58eca0e675..f75305d4c62c 100644
--- a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1.ebuild
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1.ebuild,v 1.1 2010/11/10 20:18:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/phoronix-test-suite-2.8.1.ebuild,v 1.2 2011/02/01 21:50:49 cardoe Exp $
EAPI=2
@@ -18,7 +18,7 @@ IUSE="gd gtk"
DEPEND=""
# php 5.3 doesn't have pcre useflag anymore
-RDEPEND="|| ( dev-lang/php:5.3[cli,gd,posix,pcntl,truetype] dev-lang/php:5.2[cli,gd,posix,pcntl,truetype,pcre] )
+RDEPEND="|| ( dev-lang/php:5.3[cli,curl,gd,posix,pcntl,truetype] dev-lang/php:5.2[cli,curl,gd,posix,pcntl,truetype,pcre] )
app-arch/unzip
dev-php5/pecl-ps
gtk? ( dev-php5/php-gtk )"