summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-08-27 09:07:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-08-27 09:07:03 +0000
commit194fd3ed6d5081c637609607e4fc43fcdd6bddfb (patch)
tree16c3c26db6ab9dc6af3970a26d83f825e40c305f /app-benchmarks
parentFixing ssl support for #380347 (diff)
downloadgentoo-2-194fd3ed6d5081c637609607e4fc43fcdd6bddfb.tar.gz
gentoo-2-194fd3ed6d5081c637609607e4fc43fcdd6bddfb.tar.bz2
gentoo-2-194fd3ed6d5081c637609607e4fc43fcdd6bddfb.zip
Bump for #377587
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/sysbench/ChangeLog7
-rw-r--r--app-benchmarks/sysbench/sysbench-0.4.12.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/app-benchmarks/sysbench/ChangeLog b/app-benchmarks/sysbench/ChangeLog
index 3ce9c5df4b3f..da4cae14198f 100644
--- a/app-benchmarks/sysbench/ChangeLog
+++ b/app-benchmarks/sysbench/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/sysbench
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/sysbench/ChangeLog,v 1.3 2011/08/27 08:54:27 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/sysbench/ChangeLog,v 1.4 2011/08/27 09:07:03 patrick Exp $
+
+*sysbench-0.4.12 (27 Aug 2011)
+
+ 27 Aug 2011; Patrick Lauer <patrick@gentoo.org> +sysbench-0.4.12.ebuild:
+ Bump for #377587
27 Aug 2011; Patrick Lauer <patrick@gentoo.org> sysbench-0.4.10.ebuild:
Adding aio useflag to properly handle automagic depend, bug #380353
diff --git a/app-benchmarks/sysbench/sysbench-0.4.12.ebuild b/app-benchmarks/sysbench/sysbench-0.4.12.ebuild
new file mode 100644
index 000000000000..553be1c99352
--- /dev/null
+++ b/app-benchmarks/sysbench/sysbench-0.4.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/sysbench/sysbench-0.4.12.ebuild,v 1.1 2011/08/27 09:07:03 patrick Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="System performance benchmark"
+HOMEPAGE="http://sysbench.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aio mysql"
+
+DEPEND="mysql? ( virtual/mysql )
+ aio? ( dev-libs/libaio )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eautoreconf
+ if ! use aio; then my_econf="--disable-aio"; fi
+ econf $(use_with mysql mysql /usr) $my_econf || die "econf failed"
+}
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}