summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2004-02-11 19:22:09 +0000
committerDylan Carlson <absinthe@gentoo.org>2004-02-11 19:22:09 +0000
commit056cab6dd1a49fac2edbd8dcc448eb7ca81a4002 (patch)
tree72373b35a99ece46d0946aba24f3a7539f66e4cd /app-benchmarks/volanomark
parentcleanup (Manifest recommit) (diff)
downloadgentoo-2-056cab6dd1a49fac2edbd8dcc448eb7ca81a4002.tar.gz
gentoo-2-056cab6dd1a49fac2edbd8dcc448eb7ca81a4002.tar.bz2
gentoo-2-056cab6dd1a49fac2edbd8dcc448eb7ca81a4002.zip
fixed to set correct stack sizes for x86 and amd64.
Diffstat (limited to 'app-benchmarks/volanomark')
-rw-r--r--app-benchmarks/volanomark/ChangeLog5
-rw-r--r--app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/app-benchmarks/volanomark/ChangeLog b/app-benchmarks/volanomark/ChangeLog
index f7d4fd95bd9e..4fb9019f9ce8 100644
--- a/app-benchmarks/volanomark/ChangeLog
+++ b/app-benchmarks/volanomark/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/volanomark
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/volanomark/ChangeLog,v 1.2 2004/02/10 22:33:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/volanomark/ChangeLog,v 1.3 2004/02/11 19:22:09 absinthe Exp $
+
+ 11 Feb 2004; Dylan Carlson <absinthe@gentoo.org> volanomark-2.5.0.9.ebuild:
+ fixed to set correct stack sizes for x86 and amd64.
*volanomark-2.5.0.9 (09 Feb 2004)
diff --git a/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild b/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild
index 680400e4ce1d..c6cd8ce8e309 100644
--- a/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild
+++ b/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild,v 1.1 2004/02/10 04:34:42 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild,v 1.2 2004/02/11 19:22:09 absinthe Exp $
DESCRIPTION="Java server benchmark utility"
HOMEPAGE="http://www.volano.com/benchmarks.html"
@@ -31,10 +31,18 @@ src_install() {
sed -i -e "s#^host=.*#cd /opt/${PN}\nhost=`hostname`#" \
-e 's:"$java":java:g' \
-e 's:! -f: -z :' \
+ -e 's:-Sn:-n:' \
${D}/opt/${PN}/startup.sh
sed -i -e "s#^./startup.sh#/opt/${PN}/startup.sh#g" ${D}/opt/${PN}/*.sh
+ # Set stack-size correctly for different arches
+ if [ "${ARCH}" == "amd64" ] ; then
+ sed -i -e 's:Xss96:Xss512:' ${D}/opt/${PN}/startup.sh
+ else
+ sed -i -e 's:Xss96:Xss128:' ${D}/opt/${PN}/startup.sh
+ fi
+
keepdir /opt/${PN}/logs
}