summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Cunha <tcunha@gentoo.org>2009-05-17 18:33:17 +0000
committerTiago Cunha <tcunha@gentoo.org>2009-05-17 18:33:17 +0000
commit6dc51551c32abba4ec939262fe074dba1ff0858c (patch)
tree3e70197aeb6484183faf17dfe01c946617bbe44f /app-benchmarks/stress/stress-1.0.0.ebuild
parentlibusb-compat will work fine with brltty, code inspection plus upstream says so. (diff)
downloadgentoo-2-6dc51551c32abba4ec939262fe074dba1ff0858c.tar.gz
gentoo-2-6dc51551c32abba4ec939262fe074dba1ff0858c.tar.bz2
gentoo-2-6dc51551c32abba4ec939262fe074dba1ff0858c.zip
- Use the patch from bug 261720 which:
- Avoids using -Werror during build (fixes bug 260868 reported by flameeyes). - Respects CFLAGS (fixes bug 239949 reported by flameeyes). Thus, stable sparc. (Portage version: 2.1.6.11/cvs/Linux sparc64)
Diffstat (limited to 'app-benchmarks/stress/stress-1.0.0.ebuild')
-rw-r--r--app-benchmarks/stress/stress-1.0.0.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/app-benchmarks/stress/stress-1.0.0.ebuild b/app-benchmarks/stress/stress-1.0.0.ebuild
index 34b6df82c5a3..8018ae974f2a 100644
--- a/app-benchmarks/stress/stress-1.0.0.ebuild
+++ b/app-benchmarks/stress/stress-1.0.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-1.0.0.ebuild,v 1.6 2009/05/05 19:23:57 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-1.0.0.ebuild,v 1.7 2009/05/17 18:33:17 tcunha Exp $
-inherit flag-o-matic
+inherit autotools flag-o-matic
MY_P="${PN}-${PV/_/}"
S="${WORKDIR}/${MY_P}"
@@ -12,7 +12,7 @@ SRC_URI="http://weather.ou.edu/~apw/projects/stress/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~mips ppc ppc64 ~sparc x86"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
IUSE="static"
DEPEND="sys-apps/help2man"
@@ -20,8 +20,17 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- # Force rebuild of the manpage
- rm -f "${S}"/doc/stress.1
+ cd "${S}"
+
+ # Force rebuild of the manpage.
+ rm -f doc/stress.1
+
+ # Honour Gentoo CFLAGS.
+ sed -i -e "/CFLAGS/s/-Werror//" \
+ -e "s/CFLAGS/AM_CFLAGS/" \
+ src/Makefile.am || die "sed cflags failed"
+
+ eautoreconf
}
src_compile() {