summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-12-23 03:27:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-12-23 03:27:32 +0000
commit39523eea354e7db4ad7bfe49efdbcb646c2dfa8f (patch)
tree0b66e849720004522d7b9cdf56c25e577f7de067 /app-benchmarks/siege
parentFix underlinking (missing -ldl as used by pluginserver.C) wrt #367509 by Dieg... (diff)
downloadgentoo-2-39523eea354e7db4ad7bfe49efdbcb646c2dfa8f.tar.gz
gentoo-2-39523eea354e7db4ad7bfe49efdbcb646c2dfa8f.tar.bz2
gentoo-2-39523eea354e7db4ad7bfe49efdbcb646c2dfa8f.zip
Bump for #386895, should fix #337619 too, thanks to Michael Kensington
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/siege')
-rw-r--r--app-benchmarks/siege/ChangeLog10
-rw-r--r--app-benchmarks/siege/files/siege-2.70-gentoo.diff117
-rw-r--r--app-benchmarks/siege/siege-2.70.ebuild52
3 files changed, 177 insertions, 2 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index f0b5450140b0..e731be34582a 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/siege
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.49 2010/11/10 19:07:56 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.50 2011/12/23 03:27:32 patrick Exp $
+
+*siege-2.70 (23 Dec 2011)
+
+ 23 Dec 2011; Patrick Lauer <patrick@gentoo.org> +files/siege-2.70-gentoo.diff,
+ +siege-2.70.ebuild:
+ Bump for #386895, should fix #337619 too, thanks to Michael Kensington
10 Nov 2010; Patrick Lauer <patrick@gentoo.org> siege-2.66.ebuild,
siege-2.67.ebuild:
diff --git a/app-benchmarks/siege/files/siege-2.70-gentoo.diff b/app-benchmarks/siege/files/siege-2.70-gentoo.diff
new file mode 100644
index 000000000000..ee4d006c6a1c
--- /dev/null
+++ b/app-benchmarks/siege/files/siege-2.70-gentoo.diff
@@ -0,0 +1,117 @@
+The bundled acinclude.m4 includeso ld libtool macros that
+are breaking build, and AC_PROG_SHELL is the only thing
+from it that can't be autogenerated. Since all it does
+is check for a POSIX shell, just avoid using it.
+--- configure.in
++++ configure.in
+@@ -44,7 +44,6 @@
+ dnl Program support
+ dnl
+ AC_PATH_PROG( PERL, perl, false )
+-AC_PROG_SHELL
+ AC_PROG_MAKE_SET
+ AC_PROG_INSTALL
+ case "$host_os" in
+@@ -405,7 +404,7 @@
+ dnl
+ AC_OUTPUT_COMMANDS([
+ infile=utils/siege2csv.in
+- outfile=utils/siege2csv.pl
++ outfile=utils/siege2csv
+ rm -f $outfile
+ sed -e "s|%_PREFIX%|$bindir|" \
+ -e "s|%_PERL%|$LREP|" \
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -28,7 +28,7 @@
+
+ AM_CFLAGS = $(PTHREAD_CFLAGS) $(WARN_CFLAGS) $(SSL_CFLAGS)
+
+-LDFLAGS = $(SSL_LDFLAGS) $(PTHREAD_LDFLAGS)
++LDFLAGS += $(SSL_LDFLAGS) $(PTHREAD_LDFLAGS)
+
+ LIBS = $(SSL_LIBS)
+
+Use of \b causes the T in "Transactions" to be displayed
+on the last column of the previous line.
+--- src/main.c
++++ src/main.c
+@@ -529,7 +529,7 @@
+ fprintf(stderr, "%s aborted due to excessive socket failure; you\n", program_name);
+ fprintf(stderr, "can change the failure threshold in $HOME/.%src\n", program_name);
+ }
+- fprintf(stderr, "\bTransactions:\t\t%12u hits\n", data_get_count(D));
++ fprintf(stderr, "Transactions:\t\t%12u hits\n", data_get_count(D));
+ fprintf(stderr, "Availability:\t\t%12.2f %%\n", data_get_count(D)==0 ? 0 :
+ (double)data_get_count(D) /
+ (data_get_count(D)+my.failed)
+
+--- utils/Makefile.am
++++ utils/Makefile.am
+@@ -25,7 +25,7 @@
+ WARN_CFLAGS = @WARN_CFLAGS@
+ AM_CFLAGS = $(WARN_CFLAGS)
+
+-SIEGE_UTILITIES = bombardment siege2csv.pl siege.config
++SIEGE_UTILITIES = bombardment siege2csv siege.config
+
+ DISTCLEANFILES = $(SIEGE_UTILITIES)
+
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -46,35 +46,6 @@
+
+ URLSTXT = $(sysconfdir)/urls.txt
+
+-install-exec-hook:
+- @if test -f $(SIEGERC); then \
+- if cmp -s $(srcdir)/siegerc $(SIEGERC); then echo ""; \
+- else \
+- echo ' $(INSTALL_DATA) $(srcdir)/siegerc $(SIEGERC).new'; \
+- $(INSTALL_DATA) $(srcdir)/siegerc $(SIEGERC).new; \
+- echo "#####################################################"; \
+- echo "WARNING: File $(SIEGERC) already exists."; \
+- echo " A new resource file has been installed as"; \
+- echo " $(SIEGERC).new. You may want to"; \
+- echo " consider using the newer version in order to"; \
+- echo " take advantage of any new features."; \
+- echo "#####################################################"; \
+- fi; \
+- else \
+- $(INSTALL_DATA) $(srcdir)/siegerc $(SIEGERC); \
+- fi
+- @if test -f $(URLSTXT); then \
+- if cmp -s $(srcdir)/siegerc $(URLSTXT); then echo ""; \
+- else \
+- echo "WARNING: File $(URLSTXT) already exists."; \
+- echo " It was NOT replaced with this installation."; \
+- fi; \
+- else \
+- $(mkinstalldirs) $(sysconfdir); \
+- $(INSTALL_DATA) $(srcdir)/urls.txt $(URLSTXT); \
+- fi
+-
+-
+ uninstall:
+ rm -f $(SIEGERC)
+
+bug 111057 - siege.config utility uses ${} which gets
+interpreted by bash sending the contents to stderr
+instead of ${HOME}/.siegerc
+--- doc/siegerc.in
++++ doc/siegerc.in
+@@ -9,11 +9,11 @@
+ # Variable declarations. You can set variables here
+ # for use in the directives below. Example:
+ # PROXY = proxy.joedog.org
+-# Reference variables inside ${} or $(), example:
++# Reference variables inside \${} or $(), example:
+ # proxy-host = ${PROXY}
+ # You can also reference ENVIRONMENT variables without
+ # actually declaring them, example:
+-# logfile = $(HOME)/var/siege.log
++# logfile = \$(HOME)/var/siege.log
+
+ #
+ # Signify verbose mode, true turns on verbose output
diff --git a/app-benchmarks/siege/siege-2.70.ebuild b/app-benchmarks/siege/siege-2.70.ebuild
new file mode 100644
index 000000000000..a5b3cc74f07a
--- /dev/null
+++ b/app-benchmarks/siege/siege-2.70.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.70.ebuild,v 1.1 2011/12/23 03:27:32 patrick Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion-r1 libtool autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="http://www.joedog.org/pub/siege/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+
+ # bundled macros break recent libtool
+ rm *.m4 || die "failed to remove bundled macros"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+ econf ${myconf}
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed in"
+ elog "/usr/share/doc/${PF}/"
+}