summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-11-03 21:47:24 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-11-03 21:47:24 +0000
commit0a657553695cccc02df513a024bdd67706889724 (patch)
tree5115ce5730ffc4aaa1a1bf1e20dd46a2d4ae51e1 /app-benchmarks/siege
parentMarking iprutils-2.0.15.3-r1 ~ppc for 32bit ppc64 userlands (diff)
downloadgentoo-2-0a657553695cccc02df513a024bdd67706889724.tar.gz
gentoo-2-0a657553695cccc02df513a024bdd67706889724.tar.bz2
gentoo-2-0a657553695cccc02df513a024bdd67706889724.zip
Add some sedfu to escape certain things in the siege.config script that get interpreted by bash causing what should go in ${HOME}/.siegerc to go to stderr instead, bug 111057.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-benchmarks/siege')
-rw-r--r--app-benchmarks/siege/ChangeLog8
-rw-r--r--app-benchmarks/siege/Manifest18
-rw-r--r--app-benchmarks/siege/siege-2.60.ebuild9
-rw-r--r--app-benchmarks/siege/siege-2.61.ebuild9
-rw-r--r--app-benchmarks/siege/siege-2.64.ebuild9
5 files changed, 35 insertions, 18 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index 06e13bb1c797..0ddbf66ffd39 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/siege
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.32 2005/10/14 20:25:49 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.33 2005/11/03 21:47:24 ka0ttic Exp $
+
+ 03 Nov 2005; Aaron Walker <ka0ttic@gentoo.org> siege-2.60.ebuild,
+ siege-2.61.ebuild, siege-2.64.ebuild:
+ Add some sedfu to escape certain things in the siege.config script that get
+ interpreted by bash causing what should go in ${HOME}/.siegrc to go to
+ stderr instead, bug 111057.
*siege-2.64 (14 Oct 2005)
diff --git a/app-benchmarks/siege/Manifest b/app-benchmarks/siege/Manifest
index aac233ea4de7..ae9792a4f3c6 100644
--- a/app-benchmarks/siege/Manifest
+++ b/app-benchmarks/siege/Manifest
@@ -1,20 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 79909ee6dc6c868f3c9165c96b8d4c51 ChangeLog 3587
+MD5 1eeb7bc7cc2e3a03de09c9dc1528a2d4 ChangeLog 3877
MD5 1185a0d2d8ac987001f575f8eb302327 files/digest-siege-2.60 62
MD5 777c4d7f0fca11bdfc849cb76422dde9 files/digest-siege-2.61 62
MD5 6f081910176735dfe5a4ab9bcc7203c2 files/digest-siege-2.64 62
MD5 9e437904b960c0cab42d691c8678774b files/siege-2.60-gentoo.diff 1740
MD5 16fc2e7263b085c5c027844be0fdc63f files/siege.bash-completion 783
MD5 15d8ee1460109dffd23fe7d243b750bd metadata.xml 257
-MD5 c8390cbc140a9b92aa12c49879d70e42 siege-2.60.ebuild 1230
-MD5 511ccfc31bba3b79faa278eca7c02a62 siege-2.61.ebuild 1242
-MD5 fd8342bc08ed1adfc5e738c7a9f6ff07 siege-2.64.ebuild 1524
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDUBRvEZCkKN40op4RAre5AJ0f3YSO/mz+WAZ52uYlZ7k8uhcK4QCeIi3Y
-XRSHHGtXfBly1TvzT/flONw=
-=pSTM
------END PGP SIGNATURE-----
+MD5 f502b6d5965b34ec5278c1aa027bbdbb siege-2.60.ebuild 1458
+MD5 c481e91b200a8b8a2fe50e0c2157a2e8 siege-2.61.ebuild 1470
+MD5 9837e5900c84d813eec4ca54e26cd429 siege-2.64.ebuild 1752
diff --git a/app-benchmarks/siege/siege-2.60.ebuild b/app-benchmarks/siege/siege-2.60.ebuild
index cf733115f434..b634c7041e66 100644
--- a/app-benchmarks/siege/siege-2.60.ebuild
+++ b/app-benchmarks/siege/siege-2.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.60.ebuild,v 1.10 2005/02/26 19:10:10 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.60.ebuild,v 1.11 2005/11/03 21:47:24 ka0ttic Exp $
inherit eutils bash-completion
@@ -32,6 +32,13 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
dodoc AUTHORS ChangeLog INSTALL MACHINES README KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
use ssl && dodoc README.https
diff --git a/app-benchmarks/siege/siege-2.61.ebuild b/app-benchmarks/siege/siege-2.61.ebuild
index e12813bbb1b5..bde55ee653ec 100644
--- a/app-benchmarks/siege/siege-2.61.ebuild
+++ b/app-benchmarks/siege/siege-2.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.61.ebuild,v 1.8 2005/09/08 16:52:50 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.61.ebuild,v 1.9 2005/11/03 21:47:24 ka0ttic Exp $
inherit eutils bash-completion
@@ -32,6 +32,13 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
dodoc AUTHORS ChangeLog INSTALL MACHINES README KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
use ssl && dodoc README.https
diff --git a/app-benchmarks/siege/siege-2.64.ebuild b/app-benchmarks/siege/siege-2.64.ebuild
index 9fc659985ff8..66890b3c9b30 100644
--- a/app-benchmarks/siege/siege-2.64.ebuild
+++ b/app-benchmarks/siege/siege-2.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.64.ebuild,v 1.1 2005/10/14 20:25:49 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.64.ebuild,v 1.2 2005/11/03 21:47:24 ka0ttic Exp $
inherit eutils bash-completion
@@ -42,6 +42,13 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
dobashcompletion ${FILESDIR}/${PN}.bash-completion