summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-12 19:35:23 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-12 19:35:23 +0000
commitc9be4982c1f8230e651122739a27ac1fca628b8c (patch)
tree660cdb6a25d0bd1e3b932f84c16a8f7618aa95c2 /app-benchmarks/jmeter/jmeter-2.0.1.ebuild
parentStrip unsupported flags. (Manifest recommit) (diff)
downloadgentoo-2-c9be4982c1f8230e651122739a27ac1fca628b8c.tar.gz
gentoo-2-c9be4982c1f8230e651122739a27ac1fca628b8c.tar.bz2
gentoo-2-c9be4982c1f8230e651122739a27ac1fca628b8c.zip
Fixed jikes deps. disabled jikes in 2.0.1 as it doesn't compile, patches are welcome on bugs.gentoo.org
Diffstat (limited to 'app-benchmarks/jmeter/jmeter-2.0.1.ebuild')
-rw-r--r--app-benchmarks/jmeter/jmeter-2.0.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-benchmarks/jmeter/jmeter-2.0.1.ebuild b/app-benchmarks/jmeter/jmeter-2.0.1.ebuild
index 1e145bfd386b..9a16a1a35209 100644
--- a/app-benchmarks/jmeter/jmeter-2.0.1.ebuild
+++ b/app-benchmarks/jmeter/jmeter-2.0.1.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/jmeter/jmeter-2.0.1.ebuild,v 1.1 2004/08/23 22:02:07 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/jmeter/jmeter-2.0.1.ebuild,v 1.2 2004/10/12 19:35:23 axxo Exp $
DESCRIPTION="Load test and measure performance on HTTP/FTP services and databases."
HOMEPAGE="http://jakarta.apache.org/jmeter"
SRC_URI="mirror://apache/jakarta/jmeter/source/jakarta-${P}_src.tgz"
DEPEND=">=virtual/jdk-1.3
doc? ( >=dev-java/velocity-1.4 )"
+ # jikes ( dev-java/jikes"
RDEPEND=">=virtual/jdk-1.3"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86"
-IUSE="doc jikes"
+IUSE="doc" # jikes"
S=${WORKDIR}/jakarta-${P}
src_compile () {
local antflags="package"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ #Does not compile with jikes, patches welcome at bugs.gentoo.org
+ #use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} docs-all"
use doc && cp /usr/share/velocity/lib/velocity-*.jar $S/lib
ant ${antflags} || die "compile problem"