summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-30 12:11:47 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-30 12:11:47 +0000
commit68038e81b9823f11fcfc5fdec1c18479967155e0 (patch)
tree86b73549f4fa88dabc16630450aa61a6e61fb96a /app-benchmarks/bootchart2
parentVersion bump, remove old. (diff)
downloadgentoo-2-68038e81b9823f11fcfc5fdec1c18479967155e0.tar.gz
gentoo-2-68038e81b9823f11fcfc5fdec1c18479967155e0.tar.bz2
gentoo-2-68038e81b9823f11fcfc5fdec1c18479967155e0.zip
app-benchmarks/bootchart2: Version bump, unrestrict for py3
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/bootchart2')
-rw-r--r--app-benchmarks/bootchart2/ChangeLog7
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.5.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/app-benchmarks/bootchart2/ChangeLog b/app-benchmarks/bootchart2/ChangeLog
index 57c238a713e3..2d20ded0fc63 100644
--- a/app-benchmarks/bootchart2/ChangeLog
+++ b/app-benchmarks/bootchart2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/bootchart2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.9 2012/06/14 06:31:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.10 2012/06/30 12:11:47 jlec Exp $
+
+*bootchart2-0.14.5 (30 Jun 2012)
+
+ 30 Jun 2012; Justin Lecher <jlec@gentoo.org> +bootchart2-0.14.5.ebuild:
+ Version bump, unrestrict for py3
*bootchart2-0.14.4 (14 Jun 2012)
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.5.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.5.ebuild
new file mode 100644
index 000000000000..965ee5416aec
--- /dev/null
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/bootchart2-0.14.5.ebuild,v 1.1 2012/06/30 12:11:47 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-pypy-*"
+
+inherit linux-info python systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/mmeeks/bootchart/"
+SRC_URI="mirror://github/mmeeks/bootchart/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="svg"
+
+RDEPEND="
+ !app-benchmarks/bootchart
+ dev-python/pycairo[svg?]
+ dev-python/pygtk
+ sys-apps/lsb-release"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+src_prepare() {
+ tc-export CC
+ sed \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_unitdir):g" \
+ -i Makefile || die
+ sed \
+ -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty":g' \
+ -i bootchartd.conf bootchartd.in || die
+}
+
+src_test() {
+ testing() {
+ emake test
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ export NO_PYTHON_COMPILE=0
+ export DOCDIR=/usr/share/doc/${PF}
+ default
+
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
+ keepdir /lib/bootchart/tmpfs
+
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PY_SITEDIR=$(python_get_sitedir) \
+ py-install-compile
+ }
+ python_execute_function installation
+
+ # does not like python3 as active interpreter
+ python_convert_shebangs 2 "${ED}"/usr/bin/pybootchartgui
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+}
+
+pkg_postinst() {
+ elog "If you are using an initrd during boot"
+ echo
+ elog "please add the init script to your default runlevel"
+ elog "rc-update add bootchart2 default"
+ echo
+ python_mod_optimize pybootchartgui
+}
+
+pkg_postrm() {
+ python_mod_cleanup pybootchartgui
+}