summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-11 16:26:43 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-11 16:26:43 +0000
commitbe7c0a9b8d0beffaef44d71f5ca494b8c5b8b389 (patch)
treea8f68df0fc2bc604a6556640c425a4a1ac79c9b2 /app-backup
parentRemove older versions that are no longer supported or superceded by newer sta... (diff)
downloadgentoo-2-be7c0a9b8d0beffaef44d71f5ca494b8c5b8b389.tar.gz
gentoo-2-be7c0a9b8d0beffaef44d71f5ca494b8c5b8b389.tar.bz2
gentoo-2-be7c0a9b8d0beffaef44d71f5ca494b8c5b8b389.zip
Version bumped, bug #297429 and #3199845. Added static and static-libs USE flags, bug #273337.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/dar/ChangeLog10
-rw-r--r--app-backup/dar/dar-2.3.11.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/app-backup/dar/ChangeLog b/app-backup/dar/ChangeLog
index 2dff72b1f848..128409f6f41d 100644
--- a/app-backup/dar/ChangeLog
+++ b/app-backup/dar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/dar
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.40 2009/05/22 16:34:24 matsuu Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.41 2011/05/11 16:26:43 matsuu Exp $
+
+*dar-2.3.11 (11 May 2011)
+
+ 11 May 2011; MATSUU Takuto <matsuu@gentoo.org> +dar-2.3.11.ebuild:
+ Version bumped, bug #297429 and #3199845. Added static and static-libs USE
+ flags, bug #273337.
*dar-2.3.9 (22 May 2009)
diff --git a/app-backup/dar/dar-2.3.11.ebuild b/app-backup/dar/dar-2.3.11.ebuild
new file mode 100644
index 000000000000..8a339d7184b5
--- /dev/null
+++ b/app-backup/dar/dar-2.3.11.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.3.11.ebuild,v 1.1 2011/05/11 16:26:43 matsuu Exp $
+
+EAPI="3"
+inherit confutils flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks (floppy,CDR(W),DVDR(W),zip,jazz etc.)"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl dar32 dar64 doc nls ssl static static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.3
+ >=app-arch/bzip2-1.0.2
+ acl? (
+ static? ( sys-apps/attr[static-libs] )
+ !static? ( sys-apps/attr )
+ )
+ nls? ( virtual/libintl )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ confutils_use_conflict dar32 dar64
+}
+
+src_configure() {
+ local myconf="--disable-upx"
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ use acl || myconf="${myconf} --disable-ea-support"
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ use doc || myconf="${myconf} --disable-build-html"
+ # use examples && myconf="${myconf} --enable-examples"
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl || myconf="${myconf} --disable-libcrypto-linking"
+ if ! use static ; then
+ myconf="${myconf} --disable-dar-static"
+ if ! use static-libs ; then
+ myconf="${myconf} --disable-static"
+ fi
+ fi
+
+ econf ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir=/usr/share/doc/${PF}/html install || die
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}