summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2012-10-06 23:48:23 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2012-10-06 23:48:23 +0000
commita623233b9a6bce190eee7f2feb283b5e4fb9789f (patch)
tree4b39ca2e15d182f72153d1815b93f91a027cdbc0 /app-backup
parentrestricting test per 437426, happy to add it back if it ever works right (diff)
downloadgentoo-2-a623233b9a6bce190eee7f2feb283b5e4fb9789f.tar.gz
gentoo-2-a623233b9a6bce190eee7f2feb283b5e4fb9789f.tar.bz2
gentoo-2-a623233b9a6bce190eee7f2feb283b5e4fb9789f.zip
Version bump. Drop old version. Added default config file.
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/obnam/ChangeLog8
-rw-r--r--app-backup/obnam/files/obnam.conf93
-rw-r--r--app-backup/obnam/obnam-1.2.ebuild (renamed from app-backup/obnam/obnam-1.0.ebuild)16
3 files changed, 111 insertions, 6 deletions
diff --git a/app-backup/obnam/ChangeLog b/app-backup/obnam/ChangeLog
index 89c27a827993..cb9d408fc016 100644
--- a/app-backup/obnam/ChangeLog
+++ b/app-backup/obnam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/obnam
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/ChangeLog,v 1.2 2012/07/09 00:11:45 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/ChangeLog,v 1.3 2012/10/06 23:48:23 mschiff Exp $
+
+*obnam-1.2 (06 Oct 2012)
+
+ 06 Oct 2012; Marc Schiffbauer <mschiff@gentoo.org> -obnam-1.0.ebuild,
+ +obnam-1.2.ebuild, +files/obnam.conf:
+ Version bump. Drop old version. Added default config file.
*obnam-1.1 (09 Jul 2012)
diff --git a/app-backup/obnam/files/obnam.conf b/app-backup/obnam/files/obnam.conf
new file mode 100644
index 000000000000..6f0a10584942
--- /dev/null
+++ b/app-backup/obnam/files/obnam.conf
@@ -0,0 +1,93 @@
+#
+# This is the global obnam configuration file
+#
+# see 'man obnam' for all available config options
+#
+
+[config]
+###
+### BACKUP REPOSITORY (backup destination)
+###
+### configure where to store backups and how
+###
+# name of the backup repository
+# can be a local path (or NFS mount ...) or a sftp URL
+#
+# local directory:
+#repository = /mnt/mybackupspace
+#
+# or remote via sftp
+#repository = sftp://someuser@server/path/to/backup
+#
+# enable compression of files in repository (disabled by default)
+#compress-with = deflate
+
+###
+### BACKUP ROOT(s) (backup source)
+###
+### configure what to backup and what to exclude
+###
+#root = /, /usr, /boot, /var, /opt, /home, /home/mschiff, /var/lib/vmdata
+root = /boot, /home
+#
+exclude = ^/var/tmp/, .*\.pid$, \.cache/, ^/usr/src/linux.*/, ^/var/tmp/portage/, .*/.local/share/Trash/
+#
+one-file-system = true
+
+###
+### FORGET POLICY (repository housekeeping)
+###
+### configure which backup generations to keep when
+### cleaning up repository
+keep = 72h,14d,10w,12m
+
+###
+### LOGGING
+###
+# where to write a logfile
+log = /var/log/obnam/obnam.log
+# log-level = debug
+#log-level = info
+# log-keep = 10
+# log-max = 0
+log-max = 20M
+# log-mode = 0600
+#chunk-size = 65536
+
+###
+### BACKUP ENCRYPTION
+###
+# Encryption:
+# --encrypt-with=ENCRYPT-WITH
+# PGP key with which to encrypt data in the backup
+# repository
+# --keyid=KEYID PGP key id to add to/remove from the backup repository
+# --weak-random use /dev/urandom instead of /dev/random to generate
+# symmetric keys
+# --symmetric-key-bits=SYMMETRIC-KEY-BITS
+# size of symmetric key, in bits
+
+###
+### PERFORMANCE TWEAKING
+###
+lru-size = 2000
+upload-queue-size = 4096
+
+#
+# Performance tweaking:
+# --node-size=SIZE size of B-tree nodes on disk (default: 262144)
+# --chunk-size=SIZE size of chunks of file data backed up (default:
+# 1048576)
+# --upload-queue-size=SIZE
+# length of upload queue for B-tree nodes (default:
+# 1024)
+# --lru-size=SIZE size of LRU cache for B-tree nodes (default: 500)
+# --idpath-depth=IDPATH-DEPTH
+# depth of chunk id mapping
+# --idpath-bits=IDPATH-BITS
+# chunk id level size
+# --idpath-skip=IDPATH-SKIP
+# chunk id mapping lowest bits skip
+# --chunkids-per-group=NUM
+# encode NUM chunk ids per group (1024)
+#
diff --git a/app-backup/obnam/obnam-1.0.ebuild b/app-backup/obnam/obnam-1.2.ebuild
index 8de616245c49..b68ace6124d8 100644
--- a/app-backup/obnam/obnam-1.0.ebuild
+++ b/app-backup/obnam/obnam-1.2.ebuild
@@ -1,32 +1,38 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/obnam-1.0.ebuild,v 1.1 2012/06/15 10:24:15 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/obnam-1.2.ebuild,v 1.1 2012/10/06 23:48:23 mschiff Exp $
EAPI=4
PYTHON_DEPEND="2:2.6:2.7"
PYTHON_MODNAME="${PN}lib"
+MY_P="${PN}_${PV}.orig"
inherit distutils python
DESCRIPTION="A backup program that supports encryption and deduplication"
HOMEPAGE="http://liw.fi/obnam/"
-SRC_URI="http://code.liw.fi/debian/pool/main/o/${PN}/${PN}_${PV}.orig.tar.gz"
+SRC_URI="http://code.liw.fi/debian/pool/main/o/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/larch
- dev-python/tracing
- dev-python/ttystatus
+DEPEND=">=dev-python/cliapp-1.20120630
+ dev-python/larch
dev-python/paramiko
+ dev-python/tracing
+ >=dev-python/ttystatus-0.19
"
RDEPEND="${DEPEND}"
+# S="${WORKDIR}/${MY_P}"
+
src_install() {
distutils_src_install
rm "${D}"/usr/bin/obnam-{benchmark,viewprof}
rm "${D}"/usr/share/man/man1/obnam-benchmark*
+ insinto /etc
+ doins "${FILESDIR}"/obnam.conf
}