summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-01-26 17:31:11 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-01-26 17:31:11 +0000
commitdeb04b6630c3ca50c2cae03e68c8cae86b2fdac2 (patch)
tree4ee698fdba006ed641ce6609ca3d58dd9762d770 /app-backup/spideroak-bin
parentOld. (diff)
downloadgentoo-2-deb04b6630c3ca50c2cae03e68c8cae86b2fdac2.tar.gz
gentoo-2-deb04b6630c3ca50c2cae03e68c8cae86b2fdac2.tar.bz2
gentoo-2-deb04b6630c3ca50c2cae03e68c8cae86b2fdac2.zip
Version bump. Adds USE=system-lib to use system rather than bundled libs, see bug #398313
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/spideroak-bin')
-rw-r--r--app-backup/spideroak-bin/ChangeLog9
-rw-r--r--app-backup/spideroak-bin/metadata.xml7
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-4.2.9913.ebuild154
3 files changed, 166 insertions, 4 deletions
diff --git a/app-backup/spideroak-bin/ChangeLog b/app-backup/spideroak-bin/ChangeLog
index 9852d98158e4..20409554f39d 100644
--- a/app-backup/spideroak-bin/ChangeLog
+++ b/app-backup/spideroak-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-backup/spideroak-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/spideroak-bin/ChangeLog,v 1.12 2012/01/10 01:30:11 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/spideroak-bin/ChangeLog,v 1.13 2012/01/26 17:31:11 blueness Exp $
+
+*spideroak-bin-4.2.9913 (26 Jan 2012)
+
+ 26 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
+ +spideroak-bin-4.2.9913.ebuild, metadata.xml:
+ Version bump. Adds USE="system-lib" to use system rather than bundled libs,
+ see bug #398313
10 Jan 2012; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Added myself to the maintainer list
diff --git a/app-backup/spideroak-bin/metadata.xml b/app-backup/spideroak-bin/metadata.xml
index 2dbb3caef80f..12671503d090 100644
--- a/app-backup/spideroak-bin/metadata.xml
+++ b/app-backup/spideroak-bin/metadata.xml
@@ -16,8 +16,9 @@
<name>Anthony G. Basile</name>
</maintainer>
<use>
- <flag name='headless'>Build without graphic frontend</flag>
- <flag name='pycurl-bundled'>Use bundled pycurl</flag>
- <flag name='qt-bundled'>Use bundled Qt4 libraries</flag>
+ <flag name='headless'>Build without graphic frontend</flag>
+ <flag name='pycurl-bundled'>Use bundled pycurl</flag>
+ <flag name='qt-bundled'>Use bundled Qt4 libraries</flag>
+ <flag name='system-libs'>Use the system libraries rather than bundled</flag>
</use>
</pkgmetadata>
diff --git a/app-backup/spideroak-bin/spideroak-bin-4.2.9913.ebuild b/app-backup/spideroak-bin/spideroak-bin-4.2.9913.ebuild
new file mode 100644
index 000000000000..cd5e1342bf62
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-4.2.9913.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/spideroak-bin/spideroak-bin-4.2.9913.ebuild,v 1.1 2012/01/26 17:31:11 blueness Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+REV=$(get_version_component_range 3)
+SRC_URI_BASE="https://spideroak.com/directdownload?platform=ubuntulucid"
+
+DESCRIPTION="An easy, secure and consolidated free online backup, storage, access and sharing system."
+HOMEPAGE="https://spideroak.com"
+SRC_URI="x86? ( ${SRC_URI_BASE}&arch=i386&revision=${REV} -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}&arch=x86_64&revision=${REV} -> ${P}_amd64.deb )"
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus headless system-libs"
+
+SSL_SLOT="0.9.8"
+
+DEPEND=""
+RDEPEND="
+ dbus? ( sys-apps/dbus )
+ !headless? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+ system-libs? (
+ dev-libs/openssl:$SSL_SLOT
+ net-misc/curl
+ >=sys-devel/gcc-4
+ dev-libs/glib:2
+ dev-libs/libpcre
+ media-libs/libpng:1.2
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ dev-db/sqlite:3
+ net-libs/libssh2
+ sys-libs/zlib
+ dev-lang/python:2.7
+ dev-python/pycurl
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+ rm -f control.tar.gz data.tar.gz debian-binary
+ rm -f usr/share/doc/spideroak/copyright
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/opt-path.patch
+ use headless && epatch "${FILESDIR}"/headless.patch
+
+ # Remove bundled libraries/plugins/python interpreter. Please keep this
+ # mapping in sync with the RDEPEND system-libs? ( atoms ) above, and the
+ # list of deleted files below
+ #
+ # libcrypto.so.0.$SSL_SLOT => dev-libs/openssl:$SSL_SLOT
+ # libssl.so.$SSL_SLOT => dev-libs/openssl:$SSL_SLOT
+ # libcurl.so* => net-misc/curl
+ # libexpat.so* => dev-libs/expat
+ # libgcc_s.so => >=sys-devel/gcc-4
+ # libstdc++.so* => >=sys-devel/gcc-4
+ # libpcre.so* => dev-libs/libpcre
+ # libpng12* => media-libs/libpng:1.2
+ # libQt*.so* => x11-libs/qt-core x11-libs/qt-gui
+ # libsqlite3.so* => dev-db/sqlite:3
+ # libssh2.so* => net-libs/libssh2
+ # libz.so* => sys-libs/zlib
+ #
+ # pycurl.so => dev-python/pycurl
+ #
+ # usr/lib/SpiderOak/py pyexpat.so => dev-lang/python:2.7
+ #
+ if use system-libs; then
+ for lib in \
+ libcrypto.so.$SSL_SLOT \
+ libssl.so.$SSL_SLOT \
+ libcurl.so* \
+ libexpat.so* \
+ libgcc_s.so* \
+ libpcre.so* \
+ libpng12* \
+ libQt*.so* \
+ libsqlite3.so* \
+ libssh2.so* \
+ libstdc++.so* \
+ libz.so* \
+ pycurl.so \
+ pyexpat.so
+ do
+ rm usr/lib/SpiderOak/$lib || die "rm $lib failed"
+ done
+
+ # Remove bundled python interpreter => dev-lang/python:2.7
+ rm usr/lib/SpiderOak/py || die "rm py failed"
+ fi
+}
+
+src_install() {
+ #install the executable script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOak
+
+ #install the prebundled libraries
+ dodir /opt
+ cp -pPR usr/lib/SpiderOak "${ED}"/opt/
+
+ #install the config files
+ rm -rf etc/apt
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the changelog
+ insinto /usr/share/doc/${P}
+ doins usr/share/doc/spideroak/changelog.gz
+
+ if ! use headless ; then
+ domenu usr/share/applications/spideroak.desktop
+ doicon usr/share/pixmaps/spideroak.png
+ fi
+}
+
+pkg_postinst() {
+ if use headless; then
+ einfo "For instructions on running SpiderOak without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+ if use system-libs; then
+ einfo "You have chosen to use your system libraries rather than the libraries that SpiderOak"
+ einfo "bundles with their software. The advantage to doing so is that it reduce the size of"
+ einfo "the package on your hard drive. However, upstream discourages this: see bug #398313."
+ fi
+}