summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-25 07:16:54 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-25 07:16:54 +0000
commit57fb72be85c410a6b318c31914f6e80351fb1d25 (patch)
tree87f1e842ce458ed260633f6a59bd2427b3b24043 /app-backup/rsnapshot
parentgnome-extra/gnome-activity-journal: Fix shebang for py implementation, #467066 (diff)
downloadgentoo-2-57fb72be85c410a6b318c31914f6e80351fb1d25.tar.gz
gentoo-2-57fb72be85c410a6b318c31914f6e80351fb1d25.tar.bz2
gentoo-2-57fb72be85c410a6b318c31914f6e80351fb1d25.zip
app-backup/rsnapshot: Add dev-perl/Lchown as dep, #342643
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-backup/rsnapshot')
-rw-r--r--app-backup/rsnapshot/ChangeLog7
-rw-r--r--app-backup/rsnapshot/rsnapshot-1.3.1-r2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-backup/rsnapshot/ChangeLog b/app-backup/rsnapshot/ChangeLog
index c260661c747b..c63ece62e5b5 100644
--- a/app-backup/rsnapshot/ChangeLog
+++ b/app-backup/rsnapshot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/rsnapshot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/rsnapshot/ChangeLog,v 1.34 2013/03/17 15:13:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/rsnapshot/ChangeLog,v 1.35 2013/04/25 07:16:54 jlec Exp $
+
+*rsnapshot-1.3.1-r2 (25 Apr 2013)
+
+ 25 Apr 2013; Justin Lecher <jlec@gentoo.org> +rsnapshot-1.3.1-r2.ebuild:
+ Add dev-perl/Lchown as dep, #342643
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/app-backup/rsnapshot/rsnapshot-1.3.1-r2.ebuild b/app-backup/rsnapshot/rsnapshot-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..20a4c91385b9
--- /dev/null
+++ b/app-backup/rsnapshot/rsnapshot-1.3.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/rsnapshot/rsnapshot-1.3.1-r2.ebuild,v 1.1 2013/04/25 07:16:54 jlec Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A filesystem backup utility based on rsync"
+HOMEPAGE="http://www.rsnapshot.org"
+SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8.2
+ dev-perl/Lchown
+ >=sys-apps/util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ >=net-misc/openssh-3.7.1_p2-r1
+ >=net-misc/rsync-2.6.0"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cp_al.patch
+)
+
+src_install() {
+ # Change sysconfdir to install the template file as documentation
+ # rather than in /etc.
+ emake install DESTDIR="${D}" \
+ sysconfdir="/usr/share/doc/${PF}" \
+ || die
+
+ dodoc README AUTHORS TODO ChangeLog \
+ docs/Upgrading_from_1.1 \
+ docs/HOWTOs/rsnapshot-{Mac,windows}-howto
+
+ docinto utils
+ dodoc utils/{README,rsnaptar,*.sh,*.pl}
+
+ docinto utils/rsnapshotdb
+ dodoc utils/rsnapshotdb/*
+}
+
+pkg_postinst() {
+ elog "The template configuration file has been installed as"
+ elog "/usr/share/doc/${PF}/rsnapshot.conf.default"
+ elog "Copy and edit the the above file as /etc/rsnapshot.conf"
+}