summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-23 03:21:08 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-23 03:21:08 +0000
commit86342265a4478cad7f39b8278cf80250a672d0fa (patch)
treeb86edec4b641cd8ce0bac84d7314713bc6606b80 /app-backup/duplicity
parentVersion bump. (diff)
downloadgentoo-2-86342265a4478cad7f39b8278cf80250a672d0fa.tar.gz
gentoo-2-86342265a4478cad7f39b8278cf80250a672d0fa.tar.bz2
gentoo-2-86342265a4478cad7f39b8278cf80250a672d0fa.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/ChangeLog7
-rw-r--r--app-backup/duplicity/duplicity-0.6.25.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-backup/duplicity/ChangeLog b/app-backup/duplicity/ChangeLog
index 96dba10acc94..1b131aeecafb 100644
--- a/app-backup/duplicity/ChangeLog
+++ b/app-backup/duplicity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/duplicity
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.98 2014/08/20 14:08:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.99 2014/10/23 03:21:08 radhermit Exp $
+
+*duplicity-0.6.25 (23 Oct 2014)
+
+ 23 Oct 2014; Tim Harder <radhermit@gentoo.org> +duplicity-0.6.25.ebuild:
+ Version bump.
20 Aug 2014; Raúl Porcel <armin76@gentoo.org> duplicity-0.6.23-r1.ebuild,
duplicity-0.6.24.ebuild:
diff --git a/app-backup/duplicity/duplicity-0.6.25.ebuild b/app-backup/duplicity/duplicity-0.6.25.ebuild
new file mode 100644
index 000000000000..c10307d32dbb
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.25.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.25.ebuild,v 1.1 2014/10/23 03:21:08 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/lockfile
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+# workaround until failing test is fixed
+PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}