summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-17 22:16:40 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-17 22:16:40 +0000
commit4cb756f0214427e38f678496424e4e5c9169bc9a (patch)
tree85021ff9a2b30c0d63db81b1f65610457580d4ed /app-backup/duplicity
parentx86 stable wrt bug #473558 (diff)
downloadgentoo-2-4cb756f0214427e38f678496424e4e5c9169bc9a.tar.gz
gentoo-2-4cb756f0214427e38f678496424e4e5c9169bc9a.tar.bz2
gentoo-2-4cb756f0214427e38f678496424e4e5c9169bc9a.zip
Revbump, apply patch to fix delete with paramiko backend (bug #466734, patch by Andreas Nüßlein).
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/ChangeLog9
-rw-r--r--app-backup/duplicity/duplicity-0.6.21-r1.ebuild33
-rw-r--r--app-backup/duplicity/files/duplicity-0.6.21-paramiko-delete.patch43
3 files changed, 84 insertions, 1 deletions
diff --git a/app-backup/duplicity/ChangeLog b/app-backup/duplicity/ChangeLog
index bb6cda21f2ee..8f1bd07c6fa8 100644
--- a/app-backup/duplicity/ChangeLog
+++ b/app-backup/duplicity/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-backup/duplicity
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.82 2013/06/12 22:34:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.83 2013/06/17 22:16:40 radhermit Exp $
+
+*duplicity-0.6.21-r1 (17 Jun 2013)
+
+ 17 Jun 2013; Tim Harder <radhermit@gentoo.org> +duplicity-0.6.21-r1.ebuild,
+ +files/duplicity-0.6.21-paramiko-delete.patch:
+ Revbump, apply patch to fix delete with paramiko backend (bug #466734, patch
+ by Andreas Nüßlein).
12 Jun 2013; Tim Harder <radhermit@gentoo.org> duplicity-0.6.21.ebuild:
Drop pexpect dep (paramiko ssh backend used by default).
diff --git a/app-backup/duplicity/duplicity-0.6.21-r1.ebuild b/app-backup/duplicity/duplicity-0.6.21-r1.ebuild
new file mode 100644
index 000000000000..2bdd28c2447a
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.21-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.21-r1.ebuild,v 1.1 2013/06/17 22:16:40 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3"
+
+DEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+"
+RDEPEND="${DEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ local PATCHES=( "${FILESDIR}"/${PN}-0.6.21-paramiko-delete.patch )
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.6.21-paramiko-delete.patch b/app-backup/duplicity/files/duplicity-0.6.21-paramiko-delete.patch
new file mode 100644
index 000000000000..5a9f2b7e7093
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.6.21-paramiko-delete.patch
@@ -0,0 +1,43 @@
+Fix the delete function of the paramiko backend (bug #466734).
+
+--- duplicity/backends/_ssh_paramiko.py
++++ duplicity/backends/_ssh_paramiko.py
+@@ -363,12 +363,10 @@
+ def delete(self, filename_list):
+ """deletes all files in the list on the remote side. In scp mode unavoidable quoting issues
+ will cause failures if filenames containing single quotes are encountered."""
+- for n in range(1, globals.num_retries+1):
+- if n > 1:
+- # sleep before retry
+- time.sleep(self.retry_delay)
+- try:
+- for fn in filename_list:
++ for fn in filename_list:
++ # Try to delete each file several times before giving up completely.
++ for n in range(1, globals.num_retries+1):
++ try:
+ if (globals.use_scp):
+ self.runremote("rm '%s/%s'" % (self.remote_dir,fn),False,"scp rm ")
+ else:
+@@ -376,11 +374,15 @@
+ self.sftp.remove(fn)
+ except Exception, e:
+ raise BackendException("sftp rm %s failed: %s" % (fn,e))
+- except Exception, e:
+- if n == globals.num_retries:
+- log.FatalError(str(e), log.ErrorCode.backend_error)
+- else:
+- log.Warn("%s (Try %d of %d) Will retry in %d seconds." % (e,n,globals.num_retries,self.retry_delay))
++
++ # If we get here, we deleted this file successfully. Move on to the next one.
++ break
++ except Exception, e:
++ if n == globals.num_retries:
++ log.FatalError(str(e), log.ErrorCode.backend_error)
++ else:
++ log.Warn("%s (Try %d of %d) Will retry in %d seconds." % (e,n,globals.num_retries,self.retry_delay))
++ time.sleep(self.retry_delay)
+
+ def runremote(self,cmd,ignoreexitcode=False,errorprefix=""):
+ """small convenience function that opens a shell channel, runs remote command and returns
+