summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-05-22 16:34:24 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-05-22 16:34:24 +0000
commit77c129d104a046626155f460db5470f1d9cb00f8 (patch)
treeb8f010162dee15fc70e5b58ba0a3fa6269ec8f9c /app-backup/dar
parentRemove old file; bump to latest version (2.3.7) closing bug #264331; add patc... (diff)
downloadgentoo-2-77c129d104a046626155f460db5470f1d9cb00f8.tar.gz
gentoo-2-77c129d104a046626155f460db5470f1d9cb00f8.tar.bz2
gentoo-2-77c129d104a046626155f460db5470f1d9cb00f8.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/ChangeLog9
-rw-r--r--app-backup/dar/dar-2.3.9.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/app-backup/dar/ChangeLog b/app-backup/dar/ChangeLog
index 4956187a5d90..2dff72b1f848 100644
--- a/app-backup/dar/ChangeLog
+++ b/app-backup/dar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/dar
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.39 2009/01/01 03:00:05 matsuu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.40 2009/05/22 16:34:24 matsuu Exp $
+
+*dar-2.3.9 (22 May 2009)
+
+ 22 May 2009; MATSUU Takuto <matsuu@gentoo.org> +dar-2.3.9.ebuild:
+ Version bumped.
01 Jan 2009; MATSUU Takuto <matsuu@gentoo.org> -dar-2.3.3.ebuild,
-dar-2.3.7-r1.ebuild:
diff --git a/app-backup/dar/dar-2.3.9.ebuild b/app-backup/dar/dar-2.3.9.ebuild
new file mode 100644
index 000000000000..e35586641f57
--- /dev/null
+++ b/app-backup/dar/dar-2.3.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.3.9.ebuild,v 1.1 2009/05/22 16:34:24 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks (floppy,CDR(W),DVDR(W),zip,jazz etc.)"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl dar32 dar64 doc nls ssl"
+
+RDEPEND=">=sys-libs/zlib-1.2.3
+ >=app-arch/bzip2-1.0.2
+ acl? ( sys-apps/attr )
+ nls? ( virtual/libintl )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ if use dar32 && use dar64 ; then
+ eerror "dar32 and dar64 cannot be enabled together."
+ eerror "Please remove one of them and try the emerge again."
+ die "Please remove dar32 or dar64."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^dist_noinst_DATA/s/$/ macro_tools.hpp/' \
+ -e '/^noinst_HEADERS/s/macro_tools.hpp//' \
+ src/libdar/Makefile* || die
+}
+
+src_compile() {
+ local myconf="--disable-upx"
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ use acl || myconf="${myconf} --disable-ea-support"
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ use doc || myconf="${myconf} --disable-build-html"
+ # use examples && myconf="${myconf} --enable-examples"
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl || myconf="${myconf} --disable-libcrypto-linking"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir=/usr/share/doc/${PF}/html install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}