summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-23 21:13:25 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-23 21:13:25 +0000
commit47fe80900e4cc54128265418850186c926296ad4 (patch)
treea42ed18c8f9a4786c6540792d680f33710c9c6de /app-backup/backintime
parentDepend on harfbuzz with icu (when useflag is around). (diff)
downloadgentoo-2-47fe80900e4cc54128265418850186c926296ad4.tar.gz
gentoo-2-47fe80900e4cc54128265418850186c926296ad4.tar.bz2
gentoo-2-47fe80900e4cc54128265418850186c926296ad4.zip
Version bump (bug 472552), respect LINGUAS (bug 438270).
(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-backup/backintime')
-rw-r--r--app-backup/backintime/ChangeLog11
-rw-r--r--app-backup/backintime/backintime-1.0.24.ebuild99
-rw-r--r--app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch49
3 files changed, 156 insertions, 3 deletions
diff --git a/app-backup/backintime/ChangeLog b/app-backup/backintime/ChangeLog
index ef635cb97fd4..6b2bb619440b 100644
--- a/app-backup/backintime/ChangeLog
+++ b/app-backup/backintime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/backintime
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/ChangeLog,v 1.15 2011/11/10 23:53:47 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/ChangeLog,v 1.16 2013/06/23 21:13:25 xmw Exp $
+
+*backintime-1.0.24 (23 Jun 2013)
+
+ 23 Jun 2013; Michael Weber <xmw@gentoo.org> +backintime-1.0.24.ebuild,
+ +files/backintime-1.0.24-dont-install-license.patch:
+ Version bump (bug 472552), respect LINGUAS (bug 438270).
*backintime-1.0.8-r1 (10 Nov 2011)
@@ -85,4 +91,3 @@
+metadata.xml:
initial commit - based in part on a work by Matija Suklje (hook) and
Maurice Gilden (bug #267633)
-
diff --git a/app-backup/backintime/backintime-1.0.24.ebuild b/app-backup/backintime/backintime-1.0.24.ebuild
new file mode 100644
index 000000000000..a07d694bba53
--- /dev/null
+++ b/app-backup/backintime/backintime-1.0.24.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.24.ebuild,v 1.1 2013/06/23 21:13:25 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A simple backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
+HOMEPAGE="http://backintime.le-web.org/"
+SRC_URI="http://${PN}.le-web.org/wp-content/uploads/2009/03/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde gnome"
+
+DEPEND="
+ net-misc/rsync[xattr,acl]
+ kde? (
+ >=kde-base/kdelibs-4
+ kde-base/pykde4
+ kde-base/kompare
+ kde-base/kdesu
+ )
+ gnome? (
+ gnome-base/libglade
+ dev-util/meld
+ gnome-base/gnome-session
+ dev-python/gnome-vfs-python
+ dev-python/libgnome-python
+ dev-python/pygobject:2
+ dev-python/pygtk
+ )
+ dev-python/notify-python"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dont-install-license.patch
+ epatch "${FILESDIR}"/${PN}-1.0.4-fix-configure-warning.diff
+
+ #fix doc install location
+ sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template || die
+ sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template || die
+
+ cp "${FILESDIR}"/backintime-1.0.4-kde4-root.desktop \
+ kde4/backintime-kde4-root.desktop || die
+
+ epatch "${FILESDIR}"/${PN}-1.0.6-wrapper.patch
+ sed -e "/ python /s:python:${PYTHON}:" \
+ -e "/^APP_PATH=/s:/usr:${EPREFIX}/usr:" \
+ -i common/backintime \
+ -i gnome/backintime-gnome \
+ -i kde4/backintime-kde4 || die
+
+ backintime_variants="common $(usex gnome gnome "") $(usex kde kde4 '')"
+ backintime_run() {
+ local variant
+ for variant in ${backintime_variants} ; do
+ einfo "$variant: run \"$@\""
+ cd "${S}"/${variant}
+ "${@}" || die
+ done
+ }
+
+ backintime_linguas() {
+ cd po
+ for po in *.po ; do
+ if ! has ${po/.po} ${LINGUAS} ; then
+ rm ${po} || die
+ fi
+ done
+ }
+
+ if [ -n ${LINGUAS+x} ] ; then
+ backintime_run backintime_linguas
+ fi
+}
+
+src_configure() {
+ backintime_run econf
+}
+
+src_compile() {
+ backintime_run emake
+}
+
+src_install() {
+ backintime_run emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ python_optimize "${D}"
+}
diff --git a/app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch b/app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch
new file mode 100644
index 000000000000..73ba5947e9bf
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch
@@ -0,0 +1,49 @@
+--- backintime-1.0.4/common/Makefile.template
++++ backintime-1.0.4/common/Makefile.template
+@@ -17,10 +17,6 @@
+ install -d $(DEST)/share/backintime/plugins
+ install --mode=644 plugins/*.py $(DEST)/share/backintime/plugins
+
+- #install copyright file
+- install -d $(DEST)/share/doc/backintime-common
+- install --mode=644 debian_specific/copyright $(DEST)/share/doc/backintime-common
+-
+ #install doc file(s)
+ install -d $(DEST)/share/doc/backintime
+ install --mode=644 ../AUTHORS $(DEST)/share/doc/backintime
+--- backintime-1.0.24/common/Makefile.template
++++ backintime-1.0.24/common/Makefile.template
+@@ -20,7 +20,6 @@
+ #install doc file(s)
+ install -d $(DEST)/share/doc/backintime
+ install --mode=644 ../AUTHORS $(DEST)/share/doc/backintime
+- install --mode=644 ../LICENSE $(DEST)/share/doc/backintime
+ install --mode=644 ../README $(DEST)/share/doc/backintime
+ install --mode=644 ../TRANSLATIONS $(DEST)/share/doc/backintime
+ install --mode=644 ../VERSION $(DEST)/share/doc/backintime
+--- backintime-1.0.4/gnome/Makefile.template
++++ backintime-1.0.4/gnome/Makefile.template
+@@ -15,10 +15,6 @@
+ install -d $(DEST)/share/backintime/plugins
+ install --mode=644 plugins/*.py $(DEST)/share/backintime/plugins
+
+- #install copyright file
+- install -d $(DEST)/share/doc/backintime-gnome
+- install --mode=644 ../common/debian_specific/copyright $(DEST)/share/doc/backintime-gnome
+-
+ #install man file(s)
+ install -d $(DEST)/share/man/man1
+ install --mode=644 man/C/*.gz $(DEST)/share/man/man1
+--- backintime-1.0.4/kde4/Makefile.template
++++ backintime-1.0.4/kde4/Makefile.template
+@@ -19,10 +19,6 @@
+ install -d $(DEST)/bin
+ install backintime-kde4 $(DEST)/bin
+
+- #install copyright file
+- install -d $(DEST)/share/doc/backintime-kde4
+- install --mode=644 ../common/debian_specific/copyright $(DEST)/share/doc/backintime-kde4
+-
+ #install .desktop file(s)
+ install -d $(DEST)/share/applications/kde4
+ install --mode=644 *.desktop $(DEST)/share/applications/kde4