summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-10 23:53:47 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-10 23:53:47 +0000
commit2a347d6c05854ecff6e7bd09c73764f854dba849 (patch)
treef105bade8d8b13bf459bf397106345db67f2e2c2 /app-backup/backintime
parentStable for HPPA (bug #390033). (diff)
downloadgentoo-2-2a347d6c05854ecff6e7bd09c73764f854dba849.tar.gz
gentoo-2-2a347d6c05854ecff6e7bd09c73764f854dba849.tar.bz2
gentoo-2-2a347d6c05854ecff6e7bd09c73764f854dba849.zip
Improve python code
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/backintime')
-rw-r--r--app-backup/backintime/ChangeLog8
-rw-r--r--app-backup/backintime/backintime-1.0.6.ebuild98
-rw-r--r--app-backup/backintime/backintime-1.0.8-r1.ebuild (renamed from app-backup/backintime/backintime-1.0.6-r1.ebuild)8
3 files changed, 13 insertions, 101 deletions
diff --git a/app-backup/backintime/ChangeLog b/app-backup/backintime/ChangeLog
index 3cf0f1a07c43..ef635cb97fd4 100644
--- a/app-backup/backintime/ChangeLog
+++ b/app-backup/backintime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/backintime
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/ChangeLog,v 1.14 2011/10/23 21:39:16 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/ChangeLog,v 1.15 2011/11/10 23:53:47 xmw Exp $
+
+*backintime-1.0.8-r1 (10 Nov 2011)
+
+ 10 Nov 2011; Michael Weber <xmw@gentoo.org> -backintime-1.0.6.ebuild,
+ -backintime-1.0.6-r1.ebuild, +backintime-1.0.8-r1.ebuild:
+ Improve python code (bug 308307)
23 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
backintime-1.0.6.ebuild, backintime-1.0.6-r1.ebuild, backintime-1.0.8.ebuild:
diff --git a/app-backup/backintime/backintime-1.0.6.ebuild b/app-backup/backintime/backintime-1.0.6.ebuild
deleted file mode 100644
index 548b55a17ef1..000000000000
--- a/app-backup/backintime/backintime-1.0.6.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.6.ebuild,v 1.3 2011/10/23 21:39:16 tetromino Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-
-inherit eutils python
-
-DESCRIPTION="A simple backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
-HOMEPAGE="http://backintime.le-web.org/"
-SRC_URI="http://backintime.le-web.org/download/${PN}/${P}_src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kde gnome"
-
-DEPEND="
- net-misc/rsync[xattr,acl]
- kde? (
- >=kde-base/kdelibs-4
- kde-base/pykde4
- kde-base/kompare
- kde-base/kdesu
- )
- gnome? (
- gnome-base/libglade
- dev-util/meld
- gnome-base/gnome-session
- dev-python/gnome-vfs-python
- dev-python/libgnome-python
- dev-python/pygobject:2
- dev-python/pygtk
- )
- dev-python/notify-python"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.4-dont-install-license.diff
- epatch "${FILESDIR}"/${PN}-1.0.4-fix-configure-warning.diff
- #fix doc install location
- sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template || die
- sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template || die
-
- cp "${FILESDIR}"/backintime-1.0.4-kde4-root.desktop \
- kde4/backintime-kde4-root.desktop || die
-
- epatch "${FILESDIR}"/${P}-wrapper.patch
- sed -e "/^python /s:^python:$(PYTHON -a):" \
- -e "/^APP_PATH=/s:/usr:${EPREFIX}/usr:" \
- -i common/backintime \
- -i gnome/backintime-gnome \
- -i kde4/backintime-kde4 || die
-}
-
-src_configure() {
- cd "${S}"/common || die
- econf
-
- if use kde ; then
- cd "${S}"/kde4 || die
- econf
- fi
-
- if use gnome ; then
- cd "${S}"/gnome || die
- econf
- fi
-}
-
-src_compile() {
- emake -C common || die
-
- if use kde ; then
- emake -C kd4 || die
- fi
-
- if use gnome ; then
- emake -C gnome || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" -C common install || die
-
- if use kde ; then
- emake DESTDIR="${D}" -C kde4 install || die
- fi
-
- if use gnome ; then
- emake DESTDIR="${D}" -C gnome install || die
- fi
-
- rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
-}
diff --git a/app-backup/backintime/backintime-1.0.6-r1.ebuild b/app-backup/backintime/backintime-1.0.8-r1.ebuild
index e5f8306961ad..7a2af388bedf 100644
--- a/app-backup/backintime/backintime-1.0.6-r1.ebuild
+++ b/app-backup/backintime/backintime-1.0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.6-r1.ebuild,v 1.3 2011/10/23 21:39:16 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.8-r1.ebuild,v 1.1 2011/11/10 23:53:47 xmw Exp $
EAPI="3"
@@ -38,6 +38,10 @@ DEPEND="
RDEPEND="${DEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.4-dont-install-license.diff
epatch "${FILESDIR}"/${PN}-1.0.4-fix-configure-warning.diff
@@ -48,7 +52,7 @@ src_prepare() {
cp "${FILESDIR}"/backintime-1.0.4-kde4-root.desktop \
kde4/backintime-kde4-root.desktop || die
- epatch "${FILESDIR}"/${P}-wrapper.patch
+ epatch "${FILESDIR}"/${PN}-1.0.6-wrapper.patch
sed -e "/^python /s:^python:$(PYTHON -a):" \
-e "/^APP_PATH=/s:/usr:${EPREFIX}/usr:" \
-i common/backintime \