summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2002-05-29 01:50:30 +0000
committerBen Lutgens <lamer@gentoo.org>2002-05-29 01:50:30 +0000
commitfa604588a6189f7b6c177a3c1b86a5a108beadd5 (patch)
tree9283d5531a4ba50d065a96b77b53abcb5e42730d /app-arch
parentsome dep changes (diff)
downloadgentoo-2-fa604588a6189f7b6c177a3c1b86a5a108beadd5.tar.gz
gentoo-2-fa604588a6189f7b6c177a3c1b86a5a108beadd5.tar.bz2
gentoo-2-fa604588a6189f7b6c177a3c1b86a5a108beadd5.zip
Raised the popt depend to 1.6.3 so it builds. Closes bug 3136.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/rpm-4.0.4-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-arch/rpm/rpm-4.0.4-r2.ebuild b/app-arch/rpm/rpm-4.0.4-r2.ebuild
new file mode 100644
index 000000000000..8d7561289529
--- /dev/null
+++ b/app-arch/rpm/rpm-4.0.4-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.0.4-r2.ebuild,v 1.1 2002/05/29 01:50:30 lamer Exp $
+
+# note to self: check for java deps
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Red Hat Package Management Utils"
+SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/${P}.tar.gz"
+HOMEPAGE="http://www.rpm.org/"
+
+RDEPEND="=sys-libs/db-3.2.3h-r4
+ >=sys-libs/zlib-1.1.3
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/popt-1.6"
+
+DEPEND="$RDEPEND nls? ( sys-devel/gettext )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-system-popt.diff
+ rm -rf ${S}/popt
+ # Suppress pointer warnings
+ cp configure configure.orig
+ sed -e "s:-Wpointer-arith::" configure.orig > configure
+
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man ${myconf}
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ mv ${D}/bin/rpm ${D}/usr/bin
+ rm -rf ${D}/bin
+
+ dodoc CHANGES COPYING CREDITS GROUPS README* RPM* TODO
+}
+
+pkg_postinst() {
+
+ ${ROOT}/usr/bin/rpm --initdb --root=${ROOT}
+
+}
+
+
+