summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-04-10 15:01:48 +0000
committerMichał Górny <mgorny@gentoo.org>2012-04-10 15:01:48 +0000
commitf7fdb5f9f8ae2b9b571e33df7d7837c7ddae18f0 (patch)
tree5fe85a8487da971091f1143303426a533041d8d3 /app-arch
parentStable for HPPA (bug #396075). (diff)
downloadgentoo-2-f7fdb5f9f8ae2b9b571e33df7d7837c7ddae18f0.tar.gz
gentoo-2-f7fdb5f9f8ae2b9b571e33df7d7837c7ddae18f0.tar.bz2
gentoo-2-f7fdb5f9f8ae2b9b571e33df7d7837c7ddae18f0.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libzpaq/ChangeLog9
-rw-r--r--app-arch/libzpaq/libzpaq-5.01.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-arch/libzpaq/ChangeLog b/app-arch/libzpaq/ChangeLog
index 73c40399c07f..0b46cfc77ccd 100644
--- a/app-arch/libzpaq/ChangeLog
+++ b/app-arch/libzpaq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/libzpaq
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libzpaq/ChangeLog,v 1.3 2011/08/25 10:24:36 mgorny Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libzpaq/ChangeLog,v 1.4 2012/04/10 15:01:48 mgorny Exp $
+
+*libzpaq-5.01 (10 Apr 2012)
+
+ 10 Apr 2012; Michał Górny <mgorny@gentoo.org> +libzpaq-5.01.ebuild:
+ Version bump.
*libzpaq-3.00 (25 Aug 2011)
*libzpaq-2.02a-r1 (25 Aug 2011)
diff --git a/app-arch/libzpaq/libzpaq-5.01.ebuild b/app-arch/libzpaq/libzpaq-5.01.ebuild
new file mode 100644
index 000000000000..8fa67445ccb8
--- /dev/null
+++ b/app-arch/libzpaq/libzpaq-5.01.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libzpaq/libzpaq-5.01.ebuild,v 1.1 2012/04/10 15:01:48 mgorny Exp $
+
+EAPI=3
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+MY_P=${PN}${PV/./}
+DESCRIPTION="Library to compress files or objects in the ZPAQ format"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="zpaq"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ EPATCH_OPTS+=-p1 epatch "${FILESDIR}"/0001-Add-autotools-files.patch
+ # XXX: update the patch instead when the old version is gone
+ touch libzpaqo.cpp || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-library-version=2:0:0
+ )
+
+ autotools-utils_src_configure
+}