summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-26 16:49:19 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-26 16:49:19 +0000
commitccef23e056007e55b468cd8b6677be8e11040daf (patch)
tree2f9f0a990b4198954e85f54538404b2cf84a4dfc /app-arch
parentold (diff)
downloadgentoo-2-ccef23e056007e55b468cd8b6677be8e11040daf.tar.gz
gentoo-2-ccef23e056007e55b468cd8b6677be8e11040daf.tar.bz2
gentoo-2-ccef23e056007e55b468cd8b6677be8e11040daf.zip
Add support for USE="nls static-libs threads" by Toffanin #286203 and require libtool-2 #286068 by Nicolas Cornu.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xz-utils/ChangeLog7
-rw-r--r--app-arch/xz-utils/metadata.xml3
-rw-r--r--app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild30
-rw-r--r--app-arch/xz-utils/xz-utils-9999.ebuild30
4 files changed, 43 insertions, 27 deletions
diff --git a/app-arch/xz-utils/ChangeLog b/app-arch/xz-utils/ChangeLog
index 365c70859670..796d0b7e0d2a 100644
--- a/app-arch/xz-utils/ChangeLog
+++ b/app-arch/xz-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/xz-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.4 2009/08/28 07:40:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.5 2009/09/26 16:49:19 vapier Exp $
+
+ 26 Sep 2009; Mike Frysinger <vapier@gentoo.org>
+ xz-utils-4.999.9_beta.ebuild, xz-utils-9999.ebuild, metadata.xml:
+ Add support for USE="nls static-libs threads" by Toffanin #286203 and
+ require libtool-2 #286068 by Nicolas Cornu.
*xz-utils-4.999.9_beta (28 Aug 2009)
diff --git a/app-arch/xz-utils/metadata.xml b/app-arch/xz-utils/metadata.xml
index 96a2d586367d..d8a0a4ac7912 100644
--- a/app-arch/xz-utils/metadata.xml
+++ b/app-arch/xz-utils/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
+<use>
+ <flag name="static-libs">Build static libraries</flag>
+</use>
</pkgmetadata>
diff --git a/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild b/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild
index c4a77b505f73..08256fef992b 100644
--- a/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild
+++ b/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild,v 1.1 2009/08/28 07:40:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-4.999.9_beta.ebuild,v 1.2 2009/09/26 16:49:19 vapier Exp $
# Remember: we cannot leverage autotools in this ebuild in order
# to avoid circular deps with autotools
+EAPI="2"
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://ctrl.tukaani.org/xz.git"
inherit git autotools
SRC_URI=""
- EXTRA_DEPEND="sys-devel/gettext dev-util/cvs" #272880
+ EXTRA_DEPEND="sys-devel/gettext dev-util/cvs >=sys-devel/libtool-2" #272880 286068
else
MY_P="${PN/-utils}-${PV/_}"
SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
@@ -25,7 +27,7 @@ HOMEPAGE="http://tukaani.org/xz/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE=""
+IUSE="nls static-libs +threads"
RDEPEND="!app-arch/lzma
!app-arch/lzma-utils
@@ -33,16 +35,20 @@ RDEPEND="!app-arch/lzma
DEPEND="${RDEPEND}
${EXTRA_DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- cd "${S}"
- sed -i 's:-static::' $(find -name Makefile.in)
- fi
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+}
+fi
+
+src_configure() {
+ econf \
+ --enable-dynamic=yes \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable static-libs static)
}
src_install() {
diff --git a/app-arch/xz-utils/xz-utils-9999.ebuild b/app-arch/xz-utils/xz-utils-9999.ebuild
index 01dbcc11e801..b61ce5190b1a 100644
--- a/app-arch/xz-utils/xz-utils-9999.ebuild
+++ b/app-arch/xz-utils/xz-utils-9999.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-9999.ebuild,v 1.2 2009/07/05 20:28:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-9999.ebuild,v 1.3 2009/09/26 16:49:19 vapier Exp $
# Remember: we cannot leverage autotools in this ebuild in order
# to avoid circular deps with autotools
+EAPI="2"
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://ctrl.tukaani.org/xz.git"
inherit git autotools
SRC_URI=""
- EXTRA_DEPEND="sys-devel/gettext dev-util/cvs" #272880
+ EXTRA_DEPEND="sys-devel/gettext dev-util/cvs >=sys-devel/libtool-2" #272880 286068
else
MY_P="${PN/-utils}-${PV/_}"
SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
@@ -25,7 +27,7 @@ HOMEPAGE="http://tukaani.org/xz/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE=""
+IUSE="nls static-libs +threads"
RDEPEND="!app-arch/lzma
!app-arch/lzma-utils
@@ -33,20 +35,20 @@ RDEPEND="!app-arch/lzma
DEPEND="${RDEPEND}
${EXTRA_DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- cd "${S}"
- fi
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
}
+fi
-src_compile() {
- econf --enable-dynamic || die
- emake || die
+src_configure() {
+ econf \
+ --enable-dynamic=yes \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable static-libs static)
}
src_install() {