summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-05 08:29:54 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-05 08:29:54 +0000
commitc3237be6205014691b0ba3b9af275109076c7225 (patch)
tree404a70f120e75dd767e71b7afd489c5f2342c385 /app-arch
parent*portage-2.2.0_alpha20 (05 Feb 2011) (diff)
downloadgentoo-2-c3237be6205014691b0ba3b9af275109076c7225.tar.gz
gentoo-2-c3237be6205014691b0ba3b9af275109076c7225.tar.bz2
gentoo-2-c3237be6205014691b0ba3b9af275109076c7225.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xz-utils/ChangeLog7
-rw-r--r--app-arch/xz-utils/xz-utils-5.0.1.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-arch/xz-utils/ChangeLog b/app-arch/xz-utils/ChangeLog
index e1984a3709d2..05adaa78a327 100644
--- a/app-arch/xz-utils/ChangeLog
+++ b/app-arch/xz-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/xz-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.20 2011/01/06 02:49:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.21 2011/02/05 08:29:54 vapier Exp $
+
+*xz-utils-5.0.1 (05 Feb 2011)
+
+ 05 Feb 2011; Mike Frysinger <vapier@gentoo.org> +xz-utils-5.0.1.ebuild:
+ Version bump.
06 Jan 2011; Mike Frysinger <vapier@gentoo.org> xz-utils-5.0.0.ebuild,
xz-utils-9999.ebuild:
diff --git a/app-arch/xz-utils/xz-utils-5.0.1.ebuild b/app-arch/xz-utils/xz-utils-5.0.1.ebuild
new file mode 100644
index 000000000000..287ccf000372
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-5.0.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-5.0.1.ebuild,v 1.1 2011/02/05 08:29:54 vapier Exp $
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://ctrl.tukaani.org/xz.git"
+ inherit git autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+ EXTRA_DEPEND=
+fi
+
+inherit eutils multilib
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="http://tukaani.org/xz/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="nls static-libs +threads"
+
+RDEPEND="!<app-arch/lzma-4.63
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+src_prepare() {
+ eautopoint
+ eautoreconf
+}
+fi
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ rm "${D}"/usr/share/doc/xz/COPYING* || die
+ mv "${D}"/usr/share/doc/{xz,${PF}} || die
+ prepalldocs
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/liblzma.so.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/liblzma.so.0
+}