summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-06 08:44:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-06 08:44:27 +0000
commitb28ed42d1b868a2fd9959bf5d54a590ad7fbc1f2 (patch)
treee8e816434df08877ffc908f3893a89cfb90530ff /app-arch
parentRemoved stray license file. Bug # 104660. (diff)
downloadgentoo-2-b28ed42d1b868a2fd9959bf5d54a590ad7fbc1f2.tar.gz
gentoo-2-b28ed42d1b868a2fd9959bf5d54a590ad7fbc1f2.tar.bz2
gentoo-2-b28ed42d1b868a2fd9959bf5d54a590ad7fbc1f2.zip
Updated bsdtar, unrestricted the libarchive dependency. Added patch to compile clean with latest libarchive.
(Portage version: 2.0.51.22)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bsdtar/ChangeLog9
-rw-r--r--app-arch/bsdtar/Manifest2
-rw-r--r--app-arch/bsdtar/bsdtar-1.02.031.ebuild47
-rw-r--r--app-arch/bsdtar/files/bsdtar-1.02.031-wchar.patch73
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-1.02.0311
5 files changed, 131 insertions, 1 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 991d55b21c36..806f4d4272cf 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.9 2005/08/30 18:12:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.10 2005/09/06 08:44:27 flameeyes Exp $
+
+*bsdtar-1.02.031 (06 Sep 2005)
+
+ 06 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/bsdtar-1.02.031-wchar.patch, +bsdtar-1.02.031.ebuild:
+ Updated bsdtar, unrestricted the libarchive dependency. Added patch to
+ compile clean with latest libarchive.
30 Aug 2005; Diego Pettenò <flameeyes@gentoo.org> bsdtar-1.02.030.ebuild:
Don't use ${P} for osx patch.
diff --git a/app-arch/bsdtar/Manifest b/app-arch/bsdtar/Manifest
index 5e358db7d5a8..b657db4cadbf 100644
--- a/app-arch/bsdtar/Manifest
+++ b/app-arch/bsdtar/Manifest
@@ -1,7 +1,9 @@
MD5 1305c3eeea0332d6b65566a0621d5a7c bsdtar-1.02.027-r1.ebuild 1112
MD5 8a77b3ef78adb52434b7645766209a6a ChangeLog 1644
+MD5 237fafd1cf6bf6b5047443e93f74007c bsdtar-1.02.031.ebuild 1120
MD5 237fafd1cf6bf6b5047443e93f74007c bsdtar-1.02.030.ebuild 1120
MD5 afec809b169074e5d5b0803e4f8f5ec8 metadata.xml 428
MD5 23a5ba81fd708274f460d74e61f6f10d files/bsdtar-1.02.027-osx.patch 475
MD5 7cf5fd7cad3a8974a71ce2e1622824c5 files/digest-bsdtar-1.02.027-r1 67
MD5 2a8e4734601d558f6ce4f0df1a3a7033 files/digest-bsdtar-1.02.030 67
+MD5 d02bfada963e54e1598f87a597222f0b files/digest-bsdtar-1.02.031 67
diff --git a/app-arch/bsdtar/bsdtar-1.02.031.ebuild b/app-arch/bsdtar/bsdtar-1.02.031.ebuild
new file mode 100644
index 000000000000..81fff9873e4e
--- /dev/null
+++ b/app-arch/bsdtar/bsdtar-1.02.031.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-1.02.031.ebuild,v 1.1 2005/09/06 08:44:27 flameeyes Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+IUSE="build static"
+
+# This is told to be used ( !elibc_glibc? ( dev-libs/libgnugetopt ) ) but isn't
+# linked at all
+RDEPEND="app-arch/bzip2
+ sys-libs/zlib"
+
+DEPEND="dev-libs/libarchive
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-1.02.027-osx.patch
+ epatch ${FILESDIR}/${P}-wchar.patch
+}
+
+src_compile() {
+ ( use static || use build ) && append-ldflags -static
+
+ econf --bindir=/bin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ # Create tar symlink for BSD userlands
+ if [[ ${USERLAND} == "BSD" ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1.gz /usr/share/man/man1/tar.1.gz
+ fi
+}
diff --git a/app-arch/bsdtar/files/bsdtar-1.02.031-wchar.patch b/app-arch/bsdtar/files/bsdtar-1.02.031-wchar.patch
new file mode 100644
index 000000000000..5dd560137a52
--- /dev/null
+++ b/app-arch/bsdtar/files/bsdtar-1.02.031-wchar.patch
@@ -0,0 +1,73 @@
+Index: bsdtar-1.02.031/bsdtar.c
+===================================================================
+--- bsdtar-1.02.031.orig/bsdtar.c
++++ bsdtar-1.02.031/bsdtar.c
+@@ -27,6 +27,10 @@
+ #include "bsdtar_platform.h"
+ __FBSDID("$FreeBSD: src/usr.bin/tar/bsdtar.c,v 1.64 2005/08/02 03:02:55 kientzle Exp $");
+
++#if HAVE_WCHAR_H
++#include <wchar.h>
++#endif
++
+ #include <sys/param.h>
+ #include <sys/stat.h>
+ #include <archive.h>
+Index: bsdtar-1.02.031/configure.ac
+===================================================================
+--- bsdtar-1.02.031.orig/configure.ac
++++ bsdtar-1.02.031/configure.ac
+@@ -13,7 +13,7 @@ AC_PROG_YACC
+ # Checks for header files.
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([bzlib.h fcntl.h inttypes.h langinfo.h limits.h locale.h paths.h stdint.h stdlib.h string.h sys/ioctl.h sys/param.h unistd.h zlib.h])
++AC_CHECK_HEADERS([bzlib.h fcntl.h inttypes.h langinfo.h limits.h locale.h paths.h stdint.h stdlib.h string.h sys/ioctl.h sys/param.h unistd.h wchar.h zlib.h])
+
+ # Checks for libraries.
+ AC_CHECK_LIB([z], [inflate])
+Index: bsdtar-1.02.031/read.c
+===================================================================
+--- bsdtar-1.02.031.orig/read.c
++++ bsdtar-1.02.031/read.c
+@@ -27,6 +27,10 @@
+ #include "bsdtar_platform.h"
+ __FBSDID("$FreeBSD: src/usr.bin/tar/read.c,v 1.23 2005/04/17 17:20:54 kientzle Exp $");
+
++#if HAVE_WCHAR_H
++#include <wchar.h>
++#endif
++
+ #include <sys/param.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+Index: bsdtar-1.02.031/util.c
+===================================================================
+--- bsdtar-1.02.031.orig/util.c
++++ bsdtar-1.02.031/util.c
+@@ -27,6 +27,10 @@
+ #include "bsdtar_platform.h"
+ __FBSDID("$FreeBSD: src/usr.bin/tar/util.c,v 1.13 2005/04/17 19:46:50 kientzle Exp $");
+
++#ifdef HAVE_WCHAR_H
++#include <wchar.h>
++#endif
++
+ #include <sys/stat.h>
+ #include <sys/types.h> /* Linux doesn't define mode_t, etc. in sys/stat.h. */
+ #include <archive_entry.h>
+Index: bsdtar-1.02.031/write.c
+===================================================================
+--- bsdtar-1.02.031.orig/write.c
++++ bsdtar-1.02.031/write.c
+@@ -27,6 +27,10 @@
+ #include "bsdtar_platform.h"
+ __FBSDID("$FreeBSD: src/usr.bin/tar/write.c,v 1.41 2005/05/08 06:25:15 kientzle Exp $");
+
++#ifdef HAVE_WCHAR_H
++#include <wchar.h>
++#endif
++
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #ifdef HAVE_POSIX_ACL
diff --git a/app-arch/bsdtar/files/digest-bsdtar-1.02.031 b/app-arch/bsdtar/files/digest-bsdtar-1.02.031
new file mode 100644
index 000000000000..ffa4847cf43f
--- /dev/null
+++ b/app-arch/bsdtar/files/digest-bsdtar-1.02.031
@@ -0,0 +1 @@
+MD5 4926a14f489e45fef75cf90d517f82ed bsdtar-1.02.031.tar.gz 133433