summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-05-03 11:29:36 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-05-03 11:29:36 +0000
commitaddf05b4259ae9924463ad0f686929544762ecb2 (patch)
treef574f43e0ee1bc59f7d0c9411c0af6db410be8b2 /app-arch
parentreadd amd64 as it likes this version for hardened as well (diff)
downloadgentoo-2-addf05b4259ae9924463ad0f686929544762ecb2.tar.gz
gentoo-2-addf05b4259ae9924463ad0f686929544762ecb2.tar.bz2
gentoo-2-addf05b4259ae9924463ad0f686929544762ecb2.zip
Version bump
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bsdtar/ChangeLog7
-rw-r--r--app-arch/bsdtar/bsdtar-2.1.10.ebuild82
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.1.103
3 files changed, 91 insertions, 1 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 41e0cbc09520..a2555716b915 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.64 2007/04/26 20:59:09 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.65 2007/05/03 11:29:36 drizzt Exp $
+
+*bsdtar-2.1.10 (03 May 2007)
+
+ 03 May 2007; Timothy Redaelli <drizzt@gentoo.org> +bsdtar-2.1.10.ebuild:
+ Version bump
*bsdtar-2.1.9 (26 Apr 2007)
diff --git a/app-arch/bsdtar/bsdtar-2.1.10.ebuild b/app-arch/bsdtar/bsdtar-2.1.10.ebuild
new file mode 100644
index 000000000000..a96199064734
--- /dev/null
+++ b/app-arch/bsdtar/bsdtar-2.1.10.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.1.10.ebuild,v 1.1 2007/05/03 11:29:36 drizzt Exp $
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_P="libarchive-${PV/_beta/b}"
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/libarchive-2.1.9-static.patch
+ epatch "${FILESDIR}"/libarchive-2.1.5-acl.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if use static || use build ; then
+ myconf="${myconf} --enable-static-bsdtar"
+ else
+ myconf="${myconf} --disable-static-bsdtar"
+ fi
+
+ # Upstream doesn't seem to care to fix the problems
+ # and I don't want to continue running after them.
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --bindir=/bin \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ fi
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.1.10 b/app-arch/bsdtar/files/digest-bsdtar-2.1.10
new file mode 100644
index 000000000000..480fccf49a39
--- /dev/null
+++ b/app-arch/bsdtar/files/digest-bsdtar-2.1.10
@@ -0,0 +1,3 @@
+MD5 4c8d9ed796928b9442e1765834ea930c libarchive-2.1.10.tar.gz 613805
+RMD160 c75070ee3042a235ac19a1fef32816877c894d10 libarchive-2.1.10.tar.gz 613805
+SHA256 08a4f6b7defbb102b301be9fd3072692552333413c4fd92c0ca6f2c327953446 libarchive-2.1.10.tar.gz 613805