summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-05 07:34:52 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-05 07:34:52 +0000
commit9d0f9ba62fa1fb3cba2cea5ea6bf8e10205b527e (patch)
treed35f24cb6d0c8faf16007f814e7ea1f38194077f /app-arch
parentMasking several packages for removal on 05 Dec 2006. (diff)
downloadgentoo-2-9d0f9ba62fa1fb3cba2cea5ea6bf8e10205b527e.tar.gz
gentoo-2-9d0f9ba62fa1fb3cba2cea5ea6bf8e10205b527e.tar.bz2
gentoo-2-9d0f9ba62fa1fb3cba2cea5ea6bf8e10205b527e.zip
Add support from Timothy Redaelli for FEATURES=test #154029.
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/tardy/ChangeLog6
-rw-r--r--app-arch/tardy/files/digest-tardy-1.122
-rw-r--r--app-arch/tardy/files/tardy-1.12-sort.patch35
-rw-r--r--app-arch/tardy/tardy-1.12.ebuild9
4 files changed, 50 insertions, 2 deletions
diff --git a/app-arch/tardy/ChangeLog b/app-arch/tardy/ChangeLog
index 15a8d6b960fb..24b8fb632651 100644
--- a/app-arch/tardy/ChangeLog
+++ b/app-arch/tardy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/tardy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/ChangeLog,v 1.6 2006/01/12 19:35:33 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/ChangeLog,v 1.7 2006/11/05 07:34:52 vapier Exp $
+
+ 05 Nov 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/tardy-1.12-sort.patch, tardy-1.12.ebuild:
+ Add support from Timothy Redaelli for FEATURES=test #154029.
12 Jan 2006; Rene Nussbaumer <killerfox@gentoo.org> tardy-1.12.ebuild:
Stable on hppa. See bug #117465.
diff --git a/app-arch/tardy/files/digest-tardy-1.12 b/app-arch/tardy/files/digest-tardy-1.12
index 7aee138fa86d..12c8b61b2f27 100644
--- a/app-arch/tardy/files/digest-tardy-1.12
+++ b/app-arch/tardy/files/digest-tardy-1.12
@@ -1 +1,3 @@
MD5 7cc18880df66f8e2693e3df210006b6c tardy-1.12.tar.gz 185481
+RMD160 5b4c4bb1fca84d159bbfc68a836be97196c424b0 tardy-1.12.tar.gz 185481
+SHA256 18b0a0a14b0bf7d08be3638a76cef2ddebcc4e6db8445500384f11447d69caf7 tardy-1.12.tar.gz 185481
diff --git a/app-arch/tardy/files/tardy-1.12-sort.patch b/app-arch/tardy/files/tardy-1.12-sort.patch
new file mode 100644
index 000000000000..2f23ff2bbc62
--- /dev/null
+++ b/app-arch/tardy/files/tardy-1.12-sort.patch
@@ -0,0 +1,35 @@
+handle newer sort syntax
+
+http://bugs.gentoo.org/154029
+
+--- test/00/t0010a.sh
++++ test/00/t0010a.sh
+@@ -91,7 +91,7 @@
+ LC_ALL=C
+ export LC_ALL
+
+-sort +4 < test.out > test.out2
++sort -k5 < test.out > test.out2
+ if test $? -ne 0 ; then fail; fi
+
+ cat > ok << 'fubar'
+--- test/00/t0011a.sh
++++ test/00/t0011a.sh
+@@ -82,7 +82,7 @@
+ $bin/tardy -list outfile /dev/null 2> test.out
+ if test $? -ne 0 ; then fail; fi
+
+-sort +4 < test.out > test.out2
++sort -k5 < test.out > test.out2
+ if test $? -ne 0 ; then fail; fi
+
+ cat > ok << 'fubar'
+@@ -110,7 +110,7 @@
+ $bin/tardy -list outfile /dev/null 2> test.out
+ if test $? -ne 0 ; then fail; fi
+
+-sort +4 < test.out > test.out2
++sort -k5 < test.out > test.out2
+ if test $? -ne 0 ; then fail; fi
+
+ cat > ok << 'fubar'
diff --git a/app-arch/tardy/tardy-1.12.ebuild b/app-arch/tardy/tardy-1.12.ebuild
index e018feb47783..fdd6c9408b4c 100644
--- a/app-arch/tardy/tardy-1.12.ebuild
+++ b/app-arch/tardy/tardy-1.12.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/tardy-1.12.ebuild,v 1.7 2006/01/12 19:35:33 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/tardy-1.12.ebuild,v 1.8 2006/11/05 07:34:52 vapier Exp $
+
+inherit eutils
DESCRIPTION="A tar post-processor"
HOMEPAGE="http://tardy.sourceforge.net/"
@@ -15,6 +17,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
sed -i '/^CFLAGS/d' Makefile.in
+ epatch "${FILESDIR}"/${P}-sort.patch
+}
+
+src_test() {
+ make sure || die "test failed"
}
src_install() {