summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-13 15:24:16 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-13 15:24:16 +0000
commit9855f786524fa31bf177c3e99b5566e1f2501a71 (patch)
tree650fe39d4ff06b28a52a84cc79c6e4417ee6ace6 /app-arch
parentBump eselect-ruby dependency (diff)
downloadgentoo-2-9855f786524fa31bf177c3e99b5566e1f2501a71.tar.gz
gentoo-2-9855f786524fa31bf177c3e99b5566e1f2501a71.tar.bz2
gentoo-2-9855f786524fa31bf177c3e99b5566e1f2501a71.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog7
-rw-r--r--app-arch/dpkg/dpkg-1.15.8.4.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index b9436cbf57ae..670be5f19ce0 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.137 2010/08/02 15:26:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.138 2010/08/13 15:24:16 jer Exp $
+
+*dpkg-1.15.8.4 (13 Aug 2010)
+
+ 13 Aug 2010; Jeroen Roovers <jer@gentoo.org> +dpkg-1.15.8.4.ebuild:
+ Version bump.
*dpkg-1.15.8.3 (02 Aug 2010)
diff --git a/app-arch/dpkg/dpkg-1.15.8.4.ebuild b/app-arch/dpkg/dpkg-1.15.8.4.ebuild
new file mode 100644
index 000000000000..3fc3f119cf08
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.15.8.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.4.ebuild,v 1.1 2010/08/13 15:24:16 jer Exp $
+
+EAPI=3
+
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="bzip2 dselect nls test unicode zlib"
+
+LANGS="sv de es ja fr hu pl ru"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ nls? ( app-text/po4a )
+ test? ( dev-perl/Test-Pod dev-perl/IO-String )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
+
+ # don't mess with linker optimisation, respect user's flags (don't break!)
+ sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ # On every version bump, update the version manually after establishing
+ # which tests fail (bug #310847)
+ if [[ "${PV}" = "1.15.8.3" ]]; then
+ sed -i scripts/Makefile.am -e '/850_Dpkg_Compression.t/d' \
+ || die "sed failed"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ local myconf
+ if use nls; then
+ myconf="--enable-nls $(use_with dselect)"
+ else
+ if use dselect; then
+ elog "Building dselect requires USE=nls - disabling USE=dselect..."
+ fi
+ myconf="--disable-nls --without-dselect"
+ fi
+ econf \
+ ${myconf} \
+ $(use_with bzip2 bz2) \
+ $(use_enable unicode) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --without-selinux \
+ --without-start-stop-daemon
+}
+
+src_install() {
+ strip-linguas ${LANGS}
+ if [ -z "${LINGUAS}" ] ; then
+ LINGUAS=none
+ fi
+
+ emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
+ rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
+ dodoc ChangeLog INSTALL THANKS TODO
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}