summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-02-21 15:44:53 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-02-21 15:44:53 +0000
commit9272cb883f0e2e68d0af82f1dee2200d256b6622 (patch)
tree57400b4f1b17a163f6de4753da06b5b6a733c84b /app-arch
parentFixed html docs installation problem. (diff)
downloadgentoo-2-9272cb883f0e2e68d0af82f1dee2200d256b6622.tar.gz
gentoo-2-9272cb883f0e2e68d0af82f1dee2200d256b6622.tar.bz2
gentoo-2-9272cb883f0e2e68d0af82f1dee2200d256b6622.zip
new version
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/ChangeLog4
-rw-r--r--app-arch/file-roller/file-roller-0.7.ebuild50
-rw-r--r--app-arch/file-roller/files/digest-file-roller-0.71
3 files changed, 54 insertions, 1 deletions
diff --git a/app-arch/file-roller/ChangeLog b/app-arch/file-roller/ChangeLog
index 9f1c469cca75..823ef5304722 100644
--- a/app-arch/file-roller/ChangeLog
+++ b/app-arch/file-roller/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for app-arch/file-roller
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.3 2002/02/17 01:48:11 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.4 2002/02/21 15:44:53 azarah Exp $
+
+*file-roller-0.7 (21 Feb 2002)
*file-roller-0.6 (17 Feb 2002)
diff --git a/app-arch/file-roller/file-roller-0.7.ebuild b/app-arch/file-roller/file-roller-0.7.ebuild
new file mode 100644
index 000000000000..bc30a617aa3d
--- /dev/null
+++ b/app-arch/file-roller/file-roller-0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-0.7.ebuild,v 1.1 2002/02/21 15:44:53 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="File Roller is an archive manager for the GNOME environment."
+SRC_URI="http://prdownloads.sourceforge.net/${PN/-/}/${P}.tar.gz"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ x11-libs/gtk+
+ >=gnome-base/gnome-libs-1.2.0
+ >=gnome-base/gnome-vfs-1.0.0
+ >=gnome-base/libglade-0.14
+ >=gnome-base/oaf-0.6.5
+ >=gnome-base/bonobo-1.0.0
+ >=media-libs/gdk-pixbuf-0.9.0
+ nls? ( dev-util/intltool )"
+
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
+ --sysconfdir=/etc \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
diff --git a/app-arch/file-roller/files/digest-file-roller-0.7 b/app-arch/file-roller/files/digest-file-roller-0.7
new file mode 100644
index 000000000000..3d76b0dc7cbc
--- /dev/null
+++ b/app-arch/file-roller/files/digest-file-roller-0.7
@@ -0,0 +1 @@
+MD5 c4247fd5548f7c06102d5f5881593195 file-roller-0.7.tar.gz 274856