summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-08 13:55:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-08 13:55:52 +0000
commit855b3237b6fbcbc58680399de65f3e705c0e3ecf (patch)
treea34ac79c36e3a1f746d0b28f4185d489780ba897 /app-arch
parentStable on ppc; gcc-4 related; dragonheart is fine with the move. (diff)
downloadgentoo-2-855b3237b6fbcbc58680399de65f3e705c0e3ecf.tar.gz
gentoo-2-855b3237b6fbcbc58680399de65f3e705c0e3ecf.tar.bz2
gentoo-2-855b3237b6fbcbc58680399de65f3e705c0e3ecf.zip
Replace gmake workaround with proper fix, thanks Mike in bug #139663.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zip/ChangeLog6
-rw-r--r--app-arch/zip/files/zip-2.31-make.patch13
-rw-r--r--app-arch/zip/zip-2.31-r1.ebuild4
3 files changed, 20 insertions, 3 deletions
diff --git a/app-arch/zip/ChangeLog b/app-arch/zip/ChangeLog
index 1a357cc19526..4b63ef2027ae 100644
--- a/app-arch/zip/ChangeLog
+++ b/app-arch/zip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/zip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.45 2006/07/07 15:35:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.46 2006/07/08 13:55:52 flameeyes Exp $
+
+ 08 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/zip-2.31-make.patch, zip-2.31-r1.ebuild:
+ Replace gmake workaround with proper fix, thanks Mike in bug #139663.
07 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> zip-2.31-r1.ebuild:
Use gmake instead of make when available (non-intrusive fix for FreeBSD).
diff --git a/app-arch/zip/files/zip-2.31-make.patch b/app-arch/zip/files/zip-2.31-make.patch
new file mode 100644
index 000000000000..0e862e62f275
--- /dev/null
+++ b/app-arch/zip/files/zip-2.31-make.patch
@@ -0,0 +1,13 @@
+Index: zip-2.31/unix/Makefile
+===================================================================
+--- zip-2.31.orig/unix/Makefile
++++ zip-2.31/unix/Makefile
+@@ -13,7 +13,7 @@ all:
+
+ list: all
+
+-MAKE = make -f unix/Makefile
++MAKE := $(MAKE) -f unix/Makefile
+ SHELL = /bin/sh
+ LN = ln -s
+
diff --git a/app-arch/zip/zip-2.31-r1.ebuild b/app-arch/zip/zip-2.31-r1.ebuild
index 4811e23f2eb7..2cdb7c3ef2dc 100644
--- a/app-arch/zip/zip-2.31-r1.ebuild
+++ b/app-arch/zip/zip-2.31-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.31-r1.ebuild,v 1.2 2006/07/07 15:35:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.31-r1.ebuild,v 1.3 2006/07/08 13:55:52 flameeyes Exp $
inherit toolchain-funcs eutils flag-o-matic
@@ -20,10 +20,10 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/zip-2.3-unix_configure-pic.patch
epatch "${FILESDIR}"/${P}-exec-stack.patch
+ epatch "${FILESDIR}"/${P}-make.patch
cd unix
use crypt || append-flags -DNO_CRYPT
sed -i -e "s:-O2:${CFLAGS}:" Makefile
- [[ -n $(type -p gmake) ]] && sed -i -e '/^MAKE/ s:\<make\>:gmake:' Makefile
}
src_compile() {