summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-28 01:51:57 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-28 01:51:57 +0000
commit853a09dfb144cc5f19f8d884430fe5f60586e0d3 (patch)
tree7133db08782b2d2a6d58552edc4c9fd0ea4e8b36 /app-arch
parentfixed install of plugins, too (diff)
downloadgentoo-2-853a09dfb144cc5f19f8d884430fe5f60586e0d3.tar.gz
gentoo-2-853a09dfb144cc5f19f8d884430fe5f60586e0d3.tar.bz2
gentoo-2-853a09dfb144cc5f19f8d884430fe5f60586e0d3.zip
Version bump.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/tardy/ChangeLog8
-rw-r--r--app-arch/tardy/files/tardy-1.28-test-utc.patch10
-rw-r--r--app-arch/tardy/tardy-1.28.ebuild32
3 files changed, 49 insertions, 1 deletions
diff --git a/app-arch/tardy/ChangeLog b/app-arch/tardy/ChangeLog
index cbdae7d40dc1..4e43d90155e2 100644
--- a/app-arch/tardy/ChangeLog
+++ b/app-arch/tardy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/tardy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/ChangeLog,v 1.19 2013/06/09 10:41:51 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/ChangeLog,v 1.20 2013/06/28 01:51:57 radhermit Exp $
+
+*tardy-1.28 (28 Jun 2013)
+
+ 28 Jun 2013; Tim Harder <radhermit@gentoo.org> +tardy-1.28.ebuild,
+ +files/tardy-1.28-test-utc.patch:
+ Version bump.
*tardy-1.27 (09 Jun 2013)
diff --git a/app-arch/tardy/files/tardy-1.28-test-utc.patch b/app-arch/tardy/files/tardy-1.28-test-utc.patch
new file mode 100644
index 000000000000..3f15c38020e7
--- /dev/null
+++ b/app-arch/tardy/files/tardy-1.28-test-utc.patch
@@ -0,0 +1,10 @@
+--- tardy-1.28/test/00/t0075a.sh
++++ tardy-1.28/test/00/t0075a.sh
+@@ -19,6 +19,7 @@
+
+ TEST_SUBJECT="tarballs >2GB"
+ . test_prelude
++export TZ=UTC
+
+ # |||||
+ # beware potential timezone mismatch: vvvvv
diff --git a/app-arch/tardy/tardy-1.28.ebuild b/app-arch/tardy/tardy-1.28.ebuild
new file mode 100644
index 000000000000..c5ff66820855
--- /dev/null
+++ b/app-arch/tardy/tardy-1.28.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/tardy-1.28.ebuild,v 1.1 2013/06/28 01:51:57 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A tar post-processor"
+HOMEPAGE="http://tardy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tardy/${P}.D001.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/libexplain
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e 's/$(CXX) .* $(CXXFLAGS) -I./\0 -o $@/' \
+ -e '/mv \(.*\)\.o $@/d' \
+ -e '/@sleep 1/d' \
+ -e 's#^\(install-man: $(mandir)/man1/tardy.1\).*#\1#' \
+ -i Makefile.in || die
+
+ epatch "${FILESDIR}"/${P}-test-utc.patch
+ tc-export AR
+}