summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-19 09:26:59 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-19 09:26:59 +0000
commit81ad8aab4969495971b574cad9c8d80b1d3e7442 (patch)
tree8e9d6c6b38118fb1fd5da51b9ded89124fb8fdf0 /app-arch
parentMask app-arch/p7zip[kde] as kde-base/konqueror is not keyworded (diff)
downloadgentoo-2-81ad8aab4969495971b574cad9c8d80b1d3e7442.tar.gz
gentoo-2-81ad8aab4969495971b574cad9c8d80b1d3e7442.tar.bz2
gentoo-2-81ad8aab4969495971b574cad9c8d80b1d3e7442.zip
Added pch USE and do not mix CFLAGS/CXXFLAGS
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/p7zip/ChangeLog9
-rw-r--r--app-arch/p7zip/p7zip-4.57.ebuild80
-rw-r--r--app-arch/p7zip/p7zip-4.58-r1.ebuild77
-rw-r--r--app-arch/p7zip/p7zip-4.65.ebuild127
-rw-r--r--app-arch/p7zip/p7zip-9.13-r1.ebuild (renamed from app-arch/p7zip/p7zip-9.04.ebuild)17
5 files changed, 20 insertions, 290 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index 6505d1142c9a..fb8550097532 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.128 2010/08/13 13:41:00 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.129 2010/09/19 09:26:59 jlec Exp $
+
+*p7zip-9.13-r1 (19 Sep 2010)
+
+ 19 Sep 2010; Justin Lecher <jlec@gentoo.org> -p7zip-4.57.ebuild,
+ -p7zip-4.58-r1.ebuild, -p7zip-4.65.ebuild, -p7zip-9.04.ebuild,
+ +p7zip-9.13-r1.ebuild:
+ Added pch USE and do not mix CFLAGS/CXXFLAGS
13 Aug 2010; Joseph Jezak <josejx@gentoo.org> p7zip-9.13.ebuild:
Marked ppc stable for bug #326831.
diff --git a/app-arch/p7zip/p7zip-4.57.ebuild b/app-arch/p7zip/p7zip-4.57.ebuild
deleted file mode 100644
index 63bfb58a3831..000000000000
--- a/app-arch/p7zip/p7zip-4.57.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.57.ebuild,v 1.7 2008/03/16 17:40:56 nixnut Exp $
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="Port of 7-Zip archiver for Unix"
-HOMEPAGE="http://p7zip.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="static doc"
-
-DEPEND=""
-
-S=${WORKDIR}/${PN}_${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/^CXX=/s:g++:$(tc-getCXX):" \
- -e "/^CC=/s:gcc:$(tc-getCC):" \
- -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
- -e 's:-s ::' \
- -e '/Rar/d' \
- makefile* || die "changing makefiles"
-
- if use amd64; then
- ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
- cp -f makefile.linux_amd64 makefile.machine
- elif [[ ${CHOST} == *-darwin* ]] ; then
- # Mac OS X needs this special makefile, because it has a non-GNU linker
- cp -f makefile.macosx makefile.machine
- elif use x86-fbsd; then
- # FreeBSD needs this special makefile, because it hasn't -ldl
- sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
- fi
- use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
-
- # patching to not included nonfree RAR decompression code is higher a sed call
- # But we're removing nonfree code just in case sed wasnt enough
- rm -rf CPP/7zip/Compress/Rar
-}
-
-src_compile() {
- emake all3 || die "compilation error"
-}
-
-src_install() {
- # this wrappers can not be symlinks, p7zip should be called with full path
- make_wrapper 7zr "/usr/lib/${PN}/7zr"
- make_wrapper 7za "/usr/lib/${PN}/7za"
- make_wrapper 7z "/usr/lib/${PN}/7z"
-
- dobin "${FILESDIR}/p7zip" || die
-
- # gzip introduced in 4.42, so beware :)
- # mv needed just as rename, because dobin installs using old name
- mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
- dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
-
- exeinto /usr/$(get_libdir)/${PN}
- doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
- exeinto /usr/$(get_libdir)/${PN}
- doexe bin/*.so || die "doexe *.so files"
-
- doman man1/7z.1 man1/7za.1 man1/7zr.1
- dodoc ChangeLog README TODO
-
- if use doc ; then
- dodoc DOCS/*.txt
- dohtml -r DOCS/MANUAL/*
- fi
-
- einfo "Please be aware that rar support was removed (it's nonfree)"
- einfo "You can use app-arch/rar for rar support"
-}
diff --git a/app-arch/p7zip/p7zip-4.58-r1.ebuild b/app-arch/p7zip/p7zip-4.58-r1.ebuild
deleted file mode 100644
index 5a5c9f04f988..000000000000
--- a/app-arch/p7zip/p7zip-4.58-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.58-r1.ebuild,v 1.1 2010/02/15 21:10:46 jlec Exp $
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="Port of 7-Zip archiver for Unix"
-HOMEPAGE="http://p7zip.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="static doc"
-
-DEPEND=""
-
-S=${WORKDIR}/${PN}_${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/^CXX=/s:g++:$(tc-getCXX):" \
- -e "/^CC=/s:gcc:$(tc-getCC):" \
- -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
- -e 's:-s ::' \
- -e '/Rar/d' \
- makefile* || die "changing makefiles"
-
- if use amd64; then
- cp -f makefile.linux_amd64 makefile.machine
- elif [[ ${CHOST} == *-darwin* ]] ; then
- # Mac OS X needs this special makefile, because it has a non-GNU linker
- cp -f makefile.macosx makefile.machine
- elif use x86-fbsd; then
- # FreeBSD needs this special makefile, because it hasn't -ldl
- sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
- fi
- use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
-
- # patching to not included nonfree RAR decompression code is higher a sed call
- # But we're removing nonfree code just in case sed wasnt enough
- rm -rf CPP/7zip/Compress/Rar
-}
-
-src_compile() {
- emake all3 || die "compilation error"
-}
-
-src_install() {
- # this wrappers can not be symlinks, p7zip should be called with full path
- make_wrapper 7zr "/usr/$(get_libdir)/${PN}/7zr"
- make_wrapper 7za "/usr/$(get_libdir)/${PN}/7za"
- make_wrapper 7z "/usr/$(get_libdir)/${PN}/7z"
-
- dobin "${FILESDIR}/p7zip" || die
-
- # gzip introduced in 4.42, so beware :)
- newbin contrib/gzip-like_CLI_wrapper_for_7z/p7zip 7zg || die
-
- exeinto /usr/$(get_libdir)/${PN}
- doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
- exeinto /usr/$(get_libdir)/${PN}
- doexe bin/*.so || die "doexe *.so files"
-
- doman man1/7z.1 man1/7za.1 man1/7zr.1
- dodoc ChangeLog README TODO
-
- if use doc ; then
- dodoc DOCS/*.txt
- dohtml -r DOCS/MANUAL/*
- fi
-
- einfo "Please be aware that rar support was removed (it's nonfree)"
- einfo "You can use app-arch/rar for rar support"
-}
diff --git a/app-arch/p7zip/p7zip-4.65.ebuild b/app-arch/p7zip/p7zip-4.65.ebuild
deleted file mode 100644
index 88cbeda0f8cf..000000000000
--- a/app-arch/p7zip/p7zip-4.65.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.65.ebuild,v 1.10 2010/06/07 06:43:56 jlec Exp $
-
-EAPI="2"
-WX_GTK_VER="2.8"
-
-inherit eutils toolchain-funcs multilib wxwidgets
-
-DESCRIPTION="Port of 7-Zip archiver for Unix"
-HOMEPAGE="http://p7zip.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
-
-LICENSE="LGPL-2.1 rar? ( unRAR )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc kde rar static wxwidgets"
-
-RDEPEND="kde? ( x11-libs/wxGTK:2.8[X,-odbc] kde-base/konqueror )
- wxwidgets? ( x11-libs/wxGTK:2.8[X,-odbc] )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}_${PV}
-
-pkg_setup() {
- use wxwidgets && wxwidgets_pkg_setup
-}
-
-src_prepare() {
- if use kde && ! use wxwidgets ; then
- einfo "USE-flag kde needs wxwidgets flag"
- einfo "silently enabling wxwidgets flag"
- fi
-
- # remove non-free RAR codec
- if use rar; then
- ewarn "Enabling nonfree RAR decompressor"
- else
- sed -e '/Rar/d' -i makefile*
- rm -rf CPP/7zip/Compress/Rar
- epatch "${FILESDIR}"/${PV}-makefile.patch
- fi
-
- sed -i \
- -e "/^CXX=/s:g++:$(tc-getCXX):" \
- -e "/^CC=/s:gcc:$(tc-getCC):" \
- -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
- -e 's:-s ::' \
- makefile* || die "changing makefiles"
-
- if use amd64; then
- cp -f makefile.linux_amd64 makefile.machine
- elif [[ ${CHOST} == *-darwin* ]] ; then
- # Mac OS X needs this special makefile, because it has a non-GNU linker
- cp -f makefile.macosx makefile.machine
- # bundles have extension .bundle
- sed -i -e '/^PROG=/s/\.so/.bundle/' \
- CPP/7zip/Bundles/Format7zFree/makefile || die
- elif use x86-fbsd; then
- # FreeBSD needs this special makefile, because it hasn't -ldl
- sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
- fi
- use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
-
- # We can be more parallel
- cp -f makefile.parallel_jobs makefile
-
- epatch "${FILESDIR}"/${PV}-hardlink.patch
-}
-
-src_compile() {
- emake all3 || die "compilation error"
- if use kde || use wxwidgets; then
- emake 7zG || die "error building GUI"
- fi
-}
-
-src_test() {
- emake test_7z test_7zr || die "test failed"
-}
-
-src_install() {
- # this wrappers can not be symlinks, p7zip should be called with full path
- make_wrapper 7zr "/usr/$(get_libdir)/${PN}/7zr"
- make_wrapper 7za "/usr/$(get_libdir)/${PN}/7za"
- make_wrapper 7z "/usr/$(get_libdir)/${PN}/7z"
-
- if use kde || use wxwidgets; then
- make_wrapper 7zG "/usr/$(get_libdir)/${PN}/7zG"
-
- dobin GUI/p7zipForFilemanager
- exeinto /usr/$(get_libdir)/${PN}
- doexe bin/7zG
-
- insinto /usr/$(get_libdir)/${PN}
- doins -r GUI/{Lang,help}
-
- if use kde; then
- insinto /usr/share/icons/hicolor/16x16/apps/
- newins GUI/p7zip_16_ok.png p7zip.png
-
- insinto /usr/share/apps/konqueror/servicemenus/
- doins GUI/kde/*.desktop
- fi
- fi
-
- dobin "${FILESDIR}/p7zip" || die
-
- # gzip introduced in 4.42, so beware :)
- newbin contrib/gzip-like_CLI_wrapper_for_7z/p7zip 7zg || die
-
- exeinto /usr/$(get_libdir)/${PN}
- doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
- doexe bin/*$(get_modname) || die "doexe *$(get_modname) files"
- if use rar; then
- exeinto /usr/$(get_libdir)/${PN}/Codecs/
- doexe bin/Codecs/*$(get_modname) || die "doexe Codecs/*$(get_modname) files"
- fi
-
- doman man1/7z.1 man1/7za.1 man1/7zr.1
- dodoc ChangeLog README TODO
-
- if use doc ; then
- dodoc DOCS/*.txt
- dohtml -r DOCS/MANUAL/*
- fi
-}
diff --git a/app-arch/p7zip/p7zip-9.04.ebuild b/app-arch/p7zip/p7zip-9.13-r1.ebuild
index 0edf1c783df7..405ab4092759 100644
--- a/app-arch/p7zip/p7zip-9.04.ebuild
+++ b/app-arch/p7zip/p7zip-9.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.04.ebuild,v 1.5 2010/06/07 06:43:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.13-r1.ebuild,v 1.1 2010/09/19 09:26:59 jlec Exp $
EAPI="2"
WX_GTK_VER="2.8"
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
LICENSE="LGPL-2.1 rar? ( unRAR )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc kde rar static wxwidgets"
+IUSE="doc kde rar +pch static wxwidgets"
RDEPEND="kde? ( x11-libs/wxGTK:2.8[X,-odbc] kde-base/konqueror )
wxwidgets? ( x11-libs/wxGTK:2.8[X,-odbc] )"
@@ -27,6 +27,14 @@ pkg_setup() {
}
src_prepare() {
+ if ! use pch; then
+ sed "s:PRE_COMPILED_HEADER=StdAfx.h.gch:PRE_COMPILED_HEADER=:g" -i makefile.* || die
+ fi
+
+ sed \
+ -e "/^CC/s:\$(ALLFLAGS):${CFLAGS} \$(ALLFLAGS):g" \
+ -e "/^CXX/s:\$(ALLFLAGS):${CXXFLAGS} \$(ALLFLAGS):g" \
+ -i makefile* || die
if use kde && ! use wxwidgets ; then
einfo "USE-flag kde needs wxwidgets flag"
einfo "silently enabling wxwidgets flag"
@@ -38,13 +46,12 @@ src_prepare() {
else
sed -e '/Rar/d' -i makefile*
rm -rf CPP/7zip/Compress/Rar
- epatch "${FILESDIR}"/${PV}-makefile.patch
+ epatch "${FILESDIR}"/9.04-makefile.patch
fi
sed -i \
-e "/^CXX=/s:g++:$(tc-getCXX):" \
-e "/^CC=/s:gcc:$(tc-getCC):" \
- -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
-e '/ALLFLAGS/s:-s ::' \
makefile* || die "changing makefiles"
@@ -69,7 +76,7 @@ src_prepare() {
# We can be more parallel
cp -f makefile.parallel_jobs makefile
- epatch "${FILESDIR}"/${PV}-kde4.patch
+ epatch "${FILESDIR}"/9.04-kde4.patch
if use kde || use wxwidgets; then
einfo "Preparing dependency list"