summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-08 19:13:14 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-08 19:13:14 +0000
commit78cd132542932ba0e453fbb494b9cc2ae5c97a7d (patch)
treeabfa77a8a9d6d2149c0b95b9d1bd0284e854e6b6 /app-arch
parentVersion bump #308429 by Rodrigo Severo & Dirkjan Ochtman. (diff)
downloadgentoo-2-78cd132542932ba0e453fbb494b9cc2ae5c97a7d.tar.gz
gentoo-2-78cd132542932ba0e453fbb494b9cc2ae5c97a7d.tar.bz2
gentoo-2-78cd132542932ba0e453fbb494b9cc2ae5c97a7d.zip
Fix issues on Darwin: use correct makefile, patch makefile for rar, bug #305723
(Portage version: 2.2.00.15754-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/p7zip/ChangeLog6
-rw-r--r--app-arch/p7zip/p7zip-9.04.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index cf50f4713c9d..7e9809aec44c 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.114 2010/02/16 08:19:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.115 2010/03/08 19:13:14 grobian Exp $
+
+ 08 Mar 2010; Fabian Groffen <grobian@gentoo.org> p7zip-9.04.ebuild:
+ Fix issues on Darwin: use correct makefile, patch makefile for rar, bug
+ #305723
16 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net> p7zip-9.04.ebuild:
Fix for correct symlinking, 305345
diff --git a/app-arch/p7zip/p7zip-9.04.ebuild b/app-arch/p7zip/p7zip-9.04.ebuild
index 00948611f661..76a80e1351df 100644
--- a/app-arch/p7zip/p7zip-9.04.ebuild
+++ b/app-arch/p7zip/p7zip-9.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.04.ebuild,v 1.2 2010/02/16 08:19:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.04.ebuild,v 1.3 2010/03/08 19:13:14 grobian Exp $
EAPI="2"
WX_GTK_VER="2.8"
@@ -52,10 +52,13 @@ src_prepare() {
cp -f makefile.linux_amd64 makefile.machine
elif [[ ${CHOST} == *-darwin* ]] ; then
# Mac OS X needs this special makefile, because it has a non-GNU linker
- cp -f makefile.macosx makefile.machine
+ [[ ${CHOST} == *64-* ]] \
+ && cp -f makefile.macosx_64bits makefile.machine \
+ || cp -f makefile.macosx_32bits makefile.machine
# bundles have extension .bundle
sed -i -e '/^PROG=/s/\.so/.bundle/' \
- CPP/7zip/Bundles/Format7zFree/makefile || die
+ CPP/7zip/Bundles/Format7zFree/makefile \
+ CPP/7zip/Compress/Rar/makefile || die
elif use x86-fbsd; then
# FreeBSD needs this special makefile, because it hasn't -ldl
sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine