summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-09 13:04:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-09 13:04:32 +0000
commit773693907bfbda944af5973910f47b919211f1e2 (patch)
tree5c85de9f3f492bb360412ec5ac35611b81ab5d9a /app-arch
parentBump to 0.7.12 and remove the rest of the 0.7 series. (diff)
downloadgentoo-2-773693907bfbda944af5973910f47b919211f1e2.tar.gz
gentoo-2-773693907bfbda944af5973910f47b919211f1e2.tar.bz2
gentoo-2-773693907bfbda944af5973910f47b919211f1e2.zip
Version bump, thanks zzam in bug #284233.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive/ChangeLog8
-rw-r--r--app-arch/libarchive/libarchive-2.7.1.ebuild81
2 files changed, 88 insertions, 1 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index 224fcbefc297..1d741fa0e57f 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.66 2009/08/31 15:41:06 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.67 2009/09/09 13:04:32 flameeyes Exp $
+
+*libarchive-2.7.1 (09 Sep 2009)
+
+ 09 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libarchive-2.7.1.ebuild:
+ Version bump, thanks zzam in bug #284233.
31 Aug 2009; Brent Baude <ranger@gentoo.org> libarchive-2.7.0-r1.ebuild:
Marking libarchive-2.7.0-r1 ppc64 for bug 279679
diff --git a/app-arch/libarchive/libarchive-2.7.1.ebuild b/app-arch/libarchive/libarchive-2.7.1.ebuild
new file mode 100644
index 000000000000..a9ac805f64eb
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.7.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.7.1.ebuild,v 1.1 2009/09/09 13:04:32 flameeyes Exp $
+
+EAPI=1
+
+inherit eutils libtool toolchain-funcs flag-o-matic
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
+ http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="static acl xattr kernel_linux +bzip2 +lzma +zlib"
+
+COMPRESS_LIBS_DEPEND="lzma? ( app-arch/xz-utils )
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="!dev-libs/libarchive
+ dev-libs/openssl
+ acl? ( virtual/acl )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ !static? ( ${COMPRESS_LIBS_DEPEND} )"
+DEPEND="${RDEPEND}
+ ${COMPRESS_LIBS_DEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if ! use static ; then
+ myconf="--enable-bsdtar=shared --enable-bsdcpio=shared"
+ fi
+
+ # Check for need of this in 2.7.1 and later, on 2.7.0, -Werror was
+ # added to the final release, but since it's done in the
+ # Makefile.am we can just work it around this way.
+ append-flags -Wno-error
+
+ # We disable lzmadec because we support the newer liblzma from xz-utils
+ # and not liblzmadec with this version.
+ econf --bindir=/bin \
+ --enable-bsdtar --enable-bsdcpio \
+ $(use_enable acl) $(use_enable xattr) \
+ $(use_with zlib) \
+ $(use_with bzip2 bz2lib) $(use_with lzma) \
+ --without-lzmadec \
+ ${myconf} \
+ --disable-dependency-tracking || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+
+ dodoc NEWS README
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}