summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-11-28 22:55:47 +0000
committerPacho Ramos <pacho@gentoo.org>2010-11-28 22:55:47 +0000
commit6dd898c9a445c736da6ecab92f0451e6ae5e026d (patch)
treeed7d521536bab7774042cba6f4f3ea39e18b9f7a /app-arch
parentLet this compile and work when python3 is the main interpreter (bug #315863). (diff)
downloadgentoo-2-6dd898c9a445c736da6ecab92f0451e6ae5e026d.tar.gz
gentoo-2-6dd898c9a445c736da6ecab92f0451e6ae5e026d.tar.bz2
gentoo-2-6dd898c9a445c736da6ecab92f0451e6ae5e026d.zip
Version bump, remove old.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/ChangeLog8
-rw-r--r--app-arch/file-roller/file-roller-2.32.1.ebuild (renamed from app-arch/file-roller/file-roller-2.32.0.ebuild)4
-rw-r--r--app-arch/file-roller/files/rpm2cpio-file-roller82
3 files changed, 9 insertions, 85 deletions
diff --git a/app-arch/file-roller/ChangeLog b/app-arch/file-roller/ChangeLog
index 1f9109b678e9..ca84f6cd2bac 100644
--- a/app-arch/file-roller/ChangeLog
+++ b/app-arch/file-roller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/file-roller
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.285 2010/11/20 12:08:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.286 2010/11/28 22:55:47 pacho Exp $
+
+*file-roller-2.32.1 (28 Nov 2010)
+
+ 28 Nov 2010; Pacho Ramos <pacho@gentoo.org> -files/rpm2cpio-file-roller,
+ -file-roller-2.32.0.ebuild, +file-roller-2.32.1.ebuild:
+ Version bump, remove old.
20 Nov 2010; Raúl Porcel <armin76@gentoo.org> file-roller-2.32.0.ebuild:
Add ~arm, thanks to steev for testing
diff --git a/app-arch/file-roller/file-roller-2.32.0.ebuild b/app-arch/file-roller/file-roller-2.32.1.ebuild
index 12f1ca178f66..a28e1d522433 100644
--- a/app-arch/file-roller/file-roller-2.32.0.ebuild
+++ b/app-arch/file-roller/file-roller-2.32.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.32.0.ebuild,v 1.4 2010/11/20 12:08:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.32.1.ebuild,v 1.1 2010/11/28 22:55:47 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
inherit eutils gnome2
-DESCRIPTION="archive manager for GNOME"
+DESCRIPTION="Archive manager for GNOME"
HOMEPAGE="http://fileroller.sourceforge.net/"
LICENSE="GPL-2"
diff --git a/app-arch/file-roller/files/rpm2cpio-file-roller b/app-arch/file-roller/files/rpm2cpio-file-roller
deleted file mode 100644
index 5206faee1e35..000000000000
--- a/app-arch/file-roller/files/rpm2cpio-file-roller
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/usr/bin/perl
-
-# Copyright (C) 1997,1998,1999, Roger Espel Llima
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and any associated documentation files (the "Software"), to
-# deal in the Software without restriction, including without limitation the
-# rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# SOFTWARE'S COPYRIGHT HOLDER(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-# THE SOFTWARE
-
-# (whew, that's done!)
-
-# why does the world need another rpm2cpio? because the existing one
-# won't build unless you have half a ton of things that aren't really
-# required for it, since it uses the same library used to extract RPM's.
-# in particular, it won't build on the HPsUX box i'm on.
-
-
-# add a path if desired
-$gzip = "gzip";
-
-sub printhelp {
- print "rpm2cpio, perl version by orabidoo <odar\@pobox.com>\n";
- print "use: rpm2cpio [file.rpm]\n";
- print "dumps the contents to stdout as a GNU cpio archive\n";
- exit 0;
-}
-
-if ($#ARGV == -1) {
- printhelp if -t STDIN;
- $f = "STDIN";
-} elsif ($#ARGV == 0) {
- open(F, "< $ARGV[0]") or die "Can't read file $ARGV[0]\n";
- $f = 'F';
-} else {
- printhelp;
-}
-
-printhelp if -t STDOUT;
-
-# gobble the file up
-undef $/;
-$|=1;
-$rpm = <$f>;
-close ($f);
-
-($magic, $major, $minor, $crap) = unpack("NCC C90", $rpm);
-
-die "Not an RPM\n" if $magic != 0xedabeedb;
-die "Not a version 3 RPM\n" if $major != 3;
-
-$rpm = substr($rpm, 96);
-
-while ($rpm ne '') {
- $rpm =~ s/^\c@*//s;
- ($magic, $crap, $sections, $bytes) = unpack("N4", $rpm);
- $smagic = unpack("n", $rpm);
- last if $smagic eq 0x1f8b;
- die "Error: header not recognized\n" if $magic != 0x8eade801;
- $rpm = substr($rpm, 16*(1+$sections) + $bytes);
-}
-
-die "bogus RPM\n" if $rpm eq '';
-
-open(ZCAT, "|gzip -cd") || die "can't pipe to gzip\n";
-print STDERR "CPIO archive found!\n";
-
-print ZCAT $rpm;
-close ZCAT;
-