summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2012-12-02 22:17:29 +0000
committerSven Wegener <swegener@gentoo.org>2012-12-02 22:17:29 +0000
commit6a997752e8f8980c3241e9932557c2c2eed81cdc (patch)
tree21248ea343f37db3a7d39829fe17a60db5eaa7c4 /app-arch
parentUse virtual/udev instead of sys-fs/udev wrt #444398 (diff)
downloadgentoo-2-6a997752e8f8980c3241e9932557c2c2eed81cdc.tar.gz
gentoo-2-6a997752e8f8980c3241e9932557c2c2eed81cdc.tar.bz2
gentoo-2-6a997752e8f8980c3241e9932557c2c2eed81cdc.zip
Include python support patch from bug #308291 by Ian Delaney.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/cfv/ChangeLog8
-rw-r--r--app-arch/cfv/cfv-1.18.1.ebuild19
-rw-r--r--app-arch/cfv/cfv-1.18.2.ebuild14
-rw-r--r--app-arch/cfv/cfv-1.18.3.ebuild14
4 files changed, 36 insertions, 19 deletions
diff --git a/app-arch/cfv/ChangeLog b/app-arch/cfv/ChangeLog
index a58518b6e219..047675d7bdb0 100644
--- a/app-arch/cfv/ChangeLog
+++ b/app-arch/cfv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/cfv
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/ChangeLog,v 1.37 2011/05/19 19:22:51 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/ChangeLog,v 1.38 2012/12/02 22:17:28 swegener Exp $
+
+ 02 Dec 2012; Sven Wegener <swegener@gentoo.org> cfv-1.18.1.ebuild,
+ cfv-1.18.2.ebuild, cfv-1.18.3.ebuild:
+ Include python support patch from bug #308291 by Ian Delaney.
19 May 2011; Fabian Groffen <grobian@gentoo.org> cfv-1.18.3.ebuild:
Marked ~x64-macos, bug #367895
diff --git a/app-arch/cfv/cfv-1.18.1.ebuild b/app-arch/cfv/cfv-1.18.1.ebuild
index 67746b569995..a8fccf7b21ef 100644
--- a/app-arch/cfv/cfv-1.18.1.ebuild
+++ b/app-arch/cfv/cfv-1.18.1.ebuild
@@ -1,8 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.1.ebuild,v 1.10 2008/07/02 15:04:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.1.ebuild,v 1.11 2012/12/02 22:17:29 swegener Exp $
-inherit eutils
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit python eutils
DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
HOMEPAGE="http://cfv.sourceforge.net/"
@@ -14,13 +18,9 @@ IUSE=""
KEYWORDS="amd64 hppa ppc ~sparc x86 ~x86-fbsd"
DEPEND=""
-RDEPEND="dev-lang/python
- dev-python/python-fchksum"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+RDEPEND="dev-python/python-fchksum"
+src_prepare() {
epatch "${FILESDIR}"/${P}-modulefix.patch
}
@@ -32,4 +32,5 @@ src_install() {
dobin cfv || die "dobin failed"
doman cfv.1 || die "doman failed"
dodoc README Changelog || die "dodoc failed"
+ python_convert_shebangs -r 2 "${ED}"
}
diff --git a/app-arch/cfv/cfv-1.18.2.ebuild b/app-arch/cfv/cfv-1.18.2.ebuild
index f9ef0e5af043..20bceca2d61d 100644
--- a/app-arch/cfv/cfv-1.18.2.ebuild
+++ b/app-arch/cfv/cfv-1.18.2.ebuild
@@ -1,6 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.2.ebuild,v 1.5 2009/03/17 12:06:16 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.2.ebuild,v 1.6 2012/12/02 22:17:28 swegener Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit python
DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
HOMEPAGE="http://cfv.sourceforge.net/"
@@ -12,8 +18,7 @@ IUSE=""
KEYWORDS="amd64 hppa ppc sparc x86 ~x86-fbsd"
DEPEND=""
-RDEPEND="dev-lang/python
- dev-python/python-fchksum"
+RDEPEND="dev-python/python-fchksum"
src_compile() {
true
@@ -23,4 +28,5 @@ src_install() {
dobin cfv || die "dobin failed"
doman cfv.1 || die "doman failed"
dodoc README Changelog || die "dodoc failed"
+ python_convert_shebangs -r 2 "${ED}"
}
diff --git a/app-arch/cfv/cfv-1.18.3.ebuild b/app-arch/cfv/cfv-1.18.3.ebuild
index 4c702a01d002..de2d613d5888 100644
--- a/app-arch/cfv/cfv-1.18.3.ebuild
+++ b/app-arch/cfv/cfv-1.18.3.ebuild
@@ -1,6 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.3.ebuild,v 1.4 2011/05/19 19:22:51 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.3.ebuild,v 1.5 2012/12/02 22:17:29 swegener Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit python
DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
HOMEPAGE="http://cfv.sourceforge.net/"
@@ -12,8 +18,7 @@ IUSE="bittorrent"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
DEPEND=""
-RDEPEND="dev-lang/python
- dev-python/python-fchksum
+RDEPEND="dev-python/python-fchksum
bittorrent? (
|| (
net-p2p/bittorrent
@@ -29,4 +34,5 @@ src_install() {
dobin cfv || die "dobin failed"
doman cfv.1 || die "doman failed"
dodoc README Changelog || die "dodoc failed"
+ python_convert_shebangs -r 2 "${ED}"
}