summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2014-11-23 17:45:44 +0000
committerRémi Cardona <remi@gentoo.org>2014-11-23 17:45:44 +0000
commit58bb491f370faa7247ab63fadd37042f9cf65d63 (patch)
treea5ec4db93bb34ab5f845bb55e07ceb19f8c9da9d /app-arch
parentRemove old. (diff)
downloadgentoo-2-58bb491f370faa7247ab63fadd37042f9cf65d63.tar.gz
gentoo-2-58bb491f370faa7247ab63fadd37042f9cf65d63.tar.bz2
gentoo-2-58bb491f370faa7247ab63fadd37042f9cf65d63.zip
app-arch/pax: various build fixes
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 901AB08A)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pax/ChangeLog11
-rw-r--r--app-arch/pax/files/pax-3.4-fix-fts-includes.patch24
-rw-r--r--app-arch/pax/pax-3.4.12.16-r1.ebuild39
3 files changed, 72 insertions, 2 deletions
diff --git a/app-arch/pax/ChangeLog b/app-arch/pax/ChangeLog
index 47d8270df307..bdb8e6fdee7c 100644
--- a/app-arch/pax/ChangeLog
+++ b/app-arch/pax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/pax
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pax/ChangeLog,v 1.26 2013/06/29 19:26:25 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pax/ChangeLog,v 1.27 2014/11/23 17:45:44 remi Exp $
+
+*pax-3.4.12.16-r1 (23 Nov 2014)
+
+ 23 Nov 2014; Rémi Cardona <remi@gentoo.org> +pax-3.4.12.16-r1.ebuild,
+ +files/pax-3.4-fix-fts-includes.patch:
+ Add patch to fix 'fts' includes, add needed AC_PROG_MKDIR_P with recent
+ autoconf (see bug #514308).
29 Jun 2013; Agostino Sarubbo <ago@gentoo.org> pax-3.4.12.16.ebuild:
Stable for ppc64, wrt bug #474828
diff --git a/app-arch/pax/files/pax-3.4-fix-fts-includes.patch b/app-arch/pax/files/pax-3.4-fix-fts-includes.patch
new file mode 100644
index 000000000000..5e4e37eb66aa
--- /dev/null
+++ b/app-arch/pax/files/pax-3.4-fix-fts-includes.patch
@@ -0,0 +1,24 @@
+diff -ur pax-3.4-orig/lib/fts.c pax-3.4/lib/fts.c
+--- pax-3.4-orig/lib/fts.c 2005-07-29 09:55:25.000000000 +0200
++++ pax-3.4/lib/fts.c 2014-10-30 21:38:42.404092744 +0100
+@@ -35,7 +35,7 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <errno.h>
+-#include <fts.h>
++#include "fts.h"
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+diff -ur pax-3.4-orig/src/ftree.c pax-3.4/src/ftree.c
+--- pax-3.4-orig/src/ftree.c 2005-07-29 09:46:06.000000000 +0200
++++ pax-3.4/src/ftree.c 2014-10-30 21:39:14.876093149 +0100
+@@ -46,7 +46,7 @@
+ #include <stdio.h>
+ #include <errno.h>
+ #include <stdlib.h>
+-#include <fts.h>
++#include "../lib/fts.h"
+ #include "pax.h"
+ #include "ftree.h"
+ #include "extern.h"
diff --git a/app-arch/pax/pax-3.4.12.16-r1.ebuild b/app-arch/pax/pax-3.4.12.16-r1.ebuild
new file mode 100644
index 000000000000..d5dee9c4463f
--- /dev/null
+++ b/app-arch/pax/pax-3.4.12.16-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pax/pax-3.4.12.16-r1.ebuild,v 1.1 2014/11/23 17:45:44 remi Exp $
+
+EAPI="4"
+
+inherit eutils rpm versionator autotools
+
+MY_PV=$(get_version_component_range 1-2)
+MY_P="${PN}-${MY_PV}"
+RPM_PV=$(get_version_component_range 3)
+FC_PV=$(get_version_component_range 4)
+
+DESCRIPTION="pax (Portable Archive eXchange) is the POSIX standard archive tool"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/bin/pax/"
+SRC_URI="mirror://fedora-dev/releases/${FC_PV}/Everything/source/SRPMS/${MY_P}-${RPM_PV}.fc${FC_PV}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rpm_spec_epatch ../${PN}.spec
+ epatch "${FILESDIR}"/pax-3.4-x32.patch
+ epatch "${FILESDIR}"/pax-3.4-fix-fts-includes.patch
+ sed -i configure.in \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ -e '/AC_PROG_RANLIB/a AC_PROG_MKDIR_P' \
+ || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}