summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-25 22:12:27 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-25 22:12:27 +0000
commit483b28c89d23ba2f9da0bf33a1efba3830196af9 (patch)
treee544fac2a2d5bb270b46dc8df997c245ed665b41 /app-arch
parentfix do_gcc_HTB_boundschecking_patches check and add a debug hook into the src... (diff)
downloadgentoo-2-483b28c89d23ba2f9da0bf33a1efba3830196af9.tar.gz
gentoo-2-483b28c89d23ba2f9da0bf33a1efba3830196af9.tar.bz2
gentoo-2-483b28c89d23ba2f9da0bf33a1efba3830196af9.zip
Fix the libbz2.so symlink #93867 and ldscript by psm.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/ChangeLog7
-rw-r--r--app-arch/bzip2/bzip2-1.0.3-r4.ebuild79
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.3-r41
3 files changed, 86 insertions, 1 deletions
diff --git a/app-arch/bzip2/ChangeLog b/app-arch/bzip2/ChangeLog
index 7aa1f66dc191..7426bac018e1 100644
--- a/app-arch/bzip2/ChangeLog
+++ b/app-arch/bzip2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/bzip2
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.25 2005/05/19 22:15:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.26 2005/05/25 22:12:27 vapier Exp $
+
+*bzip2-1.0.3-r4 (25 May 2005)
+
+ 25 May 2005; Mike Frysinger <vapier@gentoo.org> +bzip2-1.0.3-r4.ebuild:
+ Fix the libbz2.so symlink #93867 and ldscript by psm.
*bzip2-1.0.3-r3 (19 May 2005)
diff --git a/app-arch/bzip2/bzip2-1.0.3-r4.ebuild b/app-arch/bzip2/bzip2-1.0.3-r4.ebuild
new file mode 100644
index 000000000000..b063165c5bd7
--- /dev/null
+++ b/app-arch/bzip2/bzip2-1.0.3-r4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r4.ebuild,v 1.1 2005/05/25 22:12:27 vapier Exp $
+
+inherit eutils multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+HOMEPAGE="http://www.bzip.org/"
+SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
+
+LICENSE="BZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build static"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.2-NULL-ptr-check.patch
+ epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
+ epatch "${FILESDIR}"/${P}-saneso.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2-chmod.patch
+ sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
+
+ # - Generate symlinks instead of hardlinks
+ # - pass custom variables to control libdir
+ sed -i \
+ -e 's:ln $(PREFIX)/bin/:ln -s :' \
+ -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
+ Makefile || die "sed links"
+
+ # bzip2 will to run itself after it has built itself which we
+ # can't do if we are cross compiling. -solar
+ if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
+ sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
+ fi
+}
+
+src_compile() {
+ local makeopts="
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ RANLIB=$(tc-getRANLIB)
+ "
+ if ! use build ; then
+ emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
+ fi
+ use static && append-flags -static
+ emake ${makeopts} all || die "Make failed"
+}
+
+src_install() {
+ if ! use build ; then
+ make PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
+
+ # move bzip2 binaries to / and use the shared libbz2.so
+ mv "${D}"/usr/bin "${D}"/
+ into /
+ if ! use static ; then
+ newbin bzip2-shared bzip2 || die "dobin shared"
+ fi
+ dolib.so "${S}"/libbz2.so.${PV} || die "dolib shared"
+ for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
+ dosym libbz2.so.${PV} /$(get_libdir)/${v}
+ done
+ gen_usr_ldscript libbz2.so
+
+ dodoc README* CHANGES Y2K_INFO bzip2.txt manual.*
+ else
+ into /
+ dobin bzip2 || die "dobin bzip2"
+ fi
+
+ dosym bzip2 /bin/bzcat
+ dosym bzip2 /bin/bunzip2
+}
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3-r4 b/app-arch/bzip2/files/digest-bzip2-1.0.3-r4
new file mode 100644
index 000000000000..24bf9c7e285a
--- /dev/null
+++ b/app-arch/bzip2/files/digest-bzip2-1.0.3-r4
@@ -0,0 +1 @@
+MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075