summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-05-24 04:11:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-05-24 04:11:10 +0000
commit091911951ca7d0d673cc8e34e986ebfc9fb48836 (patch)
tree0377b380ed20b6cef180796bfd8c6d9d5d09f26f /app-arch
parentAdd games-rpg/nwn-shadowlordsdreamcatcherdemon to arch/amd64/no-multilib/pack... (diff)
downloadgentoo-2-091911951ca7d0d673cc8e34e986ebfc9fb48836.tar.gz
gentoo-2-091911951ca7d0d673cc8e34e986ebfc9fb48836.tar.bz2
gentoo-2-091911951ca7d0d673cc8e34e986ebfc9fb48836.zip
Version bump.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xz-utils/ChangeLog7
-rw-r--r--app-arch/xz-utils/xz-utils-5.0.3.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-arch/xz-utils/ChangeLog b/app-arch/xz-utils/ChangeLog
index 3cbcc691a4f8..1eb2535dbb1a 100644
--- a/app-arch/xz-utils/ChangeLog
+++ b/app-arch/xz-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/xz-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.31 2011/04/04 05:16:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.32 2011/05/24 04:11:10 vapier Exp $
+
+*xz-utils-5.0.3 (24 May 2011)
+
+ 24 May 2011; Mike Frysinger <vapier@gentoo.org> +xz-utils-5.0.3.ebuild:
+ Version bump.
*xz-utils-5.0.2 (04 Apr 2011)
diff --git a/app-arch/xz-utils/xz-utils-5.0.3.ebuild b/app-arch/xz-utils/xz-utils-5.0.3.ebuild
new file mode 100644
index 000000000000..92b789761f20
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-5.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-5.0.3.ebuild,v 1.1 2011/05/24 04:11:10 vapier Exp $
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://ctrl.tukaani.org/xz.git"
+ inherit git autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+ EXTRA_DEPEND=
+fi
+
+inherit eutils multilib
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="http://tukaani.org/xz/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="nls static-libs +threads"
+
+RDEPEND="!<app-arch/lzma-4.63
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+src_prepare() {
+ eautopoint
+ eautoreconf
+}
+fi
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ rm "${D}"/usr/share/doc/xz/COPYING* || die
+ mv "${D}"/usr/share/doc/{xz,${PF}} || die
+ prepalldocs
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/liblzma.so.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/liblzma.so.0
+}