summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-20 14:22:19 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-20 14:22:19 +0000
commitf8e9aa9569a896fbebdaa08eea6555551ff15c18 (patch)
tree34a53afe73cb687f5444fd0a0e72bf81062098a9 /app-arch/zpaq
parentVersion bump. Increase EAPI and introduce sub-slot for SONAME. (diff)
downloadgentoo-2-f8e9aa9569a896fbebdaa08eea6555551ff15c18.tar.gz
gentoo-2-f8e9aa9569a896fbebdaa08eea6555551ff15c18.tar.bz2
gentoo-2-f8e9aa9569a896fbebdaa08eea6555551ff15c18.zip
Version bump. Require exact version match between the library and archiver.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'app-arch/zpaq')
-rw-r--r--app-arch/zpaq/ChangeLog10
-rw-r--r--app-arch/zpaq/zpaq-6.10.ebuild6
-rw-r--r--app-arch/zpaq/zpaq-6.38.ebuild45
3 files changed, 56 insertions, 5 deletions
diff --git a/app-arch/zpaq/ChangeLog b/app-arch/zpaq/ChangeLog
index ae576dae2e1f..8c79102fe6d1 100644
--- a/app-arch/zpaq/ChangeLog
+++ b/app-arch/zpaq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/zpaq
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/ChangeLog,v 1.11 2012/10/14 08:00:29 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/ChangeLog,v 1.12 2013/07/20 14:22:19 mgorny Exp $
+
+*zpaq-6.38 (20 Jul 2013)
+
+ 20 Jul 2013; Michał Górny <mgorny@gentoo.org> +zpaq-6.38.ebuild,
+ zpaq-6.10.ebuild:
+ Version bump. Require exact version match between the library and archiver.
14 Oct 2012; Michał Górny <mgorny@gentoo.org> -zpaq-2.05.ebuild,
-zpaq-3.01.ebuild:
diff --git a/app-arch/zpaq/zpaq-6.10.ebuild b/app-arch/zpaq/zpaq-6.10.ebuild
index cd621973017a..c615e88fa7fc 100644
--- a/app-arch/zpaq/zpaq-6.10.ebuild
+++ b/app-arch/zpaq/zpaq-6.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/zpaq-6.10.ebuild,v 1.1 2012/10/14 07:43:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/zpaq-6.10.ebuild,v 1.2 2013/07/20 14:22:19 mgorny Exp $
EAPI=3
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-RDEPEND="=app-arch/libzpaq-6*
+RDEPEND="=app-arch/libzpaq-${PV}
dev-libs/libdivsufsort"
DEPEND="${RDEPEND}
app-arch/unzip"
diff --git a/app-arch/zpaq/zpaq-6.38.ebuild b/app-arch/zpaq/zpaq-6.38.ebuild
new file mode 100644
index 000000000000..b43eadb94ec9
--- /dev/null
+++ b/app-arch/zpaq/zpaq-6.38.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/zpaq-6.38.ebuild,v 1.1 2013/07/20 14:22:19 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
+
+MY_P=${PN}${PV/./}
+DESCRIPTION="Journaling incremental deduplicating archiving compressor"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="=app-arch/libzpaq-${PV}
+ dev-libs/libdivsufsort"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ EPATCH_OPTS+=-p1 epatch "${FILESDIR}"/${PN}-4-autotools.patch
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ # man-page is no longer there
+ ac_cv_prog_POD2MAN=
+ )
+
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "You may also want to install app-arch/zpaq-extras package which provides"
+ elog "few additional configs and preprocessors for use with zpaq."
+}