summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-25 00:29:08 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-25 00:29:08 +0000
commit97cff1b5a80684aa2e46118bb8be0c8feccf16ad (patch)
tree80dbedaad922cc5135ebce12501ccc99a6d329ef /app-arch/zip
parentMake sure we pull in latest autoconf-wrapper #238368 by Josef Reidinger. (diff)
downloadgentoo-2-97cff1b5a80684aa2e46118bb8be0c8feccf16ad.tar.gz
gentoo-2-97cff1b5a80684aa2e46118bb8be0c8feccf16ad.tar.bz2
gentoo-2-97cff1b5a80684aa2e46118bb8be0c8feccf16ad.zip
Fix building with USE=-crypt #238398 by Nils Larsson.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'app-arch/zip')
-rw-r--r--app-arch/zip/ChangeLog6
-rw-r--r--app-arch/zip/files/zip-3.0-no-crypt.patch57
-rw-r--r--app-arch/zip/zip-3.0.ebuild3
3 files changed, 64 insertions, 2 deletions
diff --git a/app-arch/zip/ChangeLog b/app-arch/zip/ChangeLog
index 1ec46ed2e4f4..d6e35cd3acdc 100644
--- a/app-arch/zip/ChangeLog
+++ b/app-arch/zip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/zip
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.75 2008/09/21 10:08:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.76 2008/09/25 00:29:08 vapier Exp $
+
+ 25 Sep 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/zip-3.0-no-crypt.patch, zip-3.0.ebuild:
+ Fix building with USE=-crypt #238398 by Nils Larsson.
*zip-3.0 (21 Sep 2008)
diff --git a/app-arch/zip/files/zip-3.0-no-crypt.patch b/app-arch/zip/files/zip-3.0-no-crypt.patch
new file mode 100644
index 000000000000..2858b51ec2c9
--- /dev/null
+++ b/app-arch/zip/files/zip-3.0-no-crypt.patch
@@ -0,0 +1,57 @@
+fix building when NO_CRYPT is used
+
+forward ported from zip-2.32
+
+http://bugs.gentoo.org/238398
+
+--- zip.c
++++ zip.c
+@@ -3452,6 +3452,9 @@ char **argv; /* command line tokens */
+
+ /* Key not yet specified. If needed, get/verify it now. */
+ if (key_needed) {
++#if !CRYPT
++ ZIPERR(ZE_PARMS, "encryption not supported");
++#else /* CRYPT */
+ if ((key = malloc(IZ_PWLEN+1)) == NULL) {
+ ZIPERR(ZE_MEM, "was getting encryption password");
+ }
+@@ -3478,6 +3481,7 @@ char **argv; /* command line tokens */
+ if (r) {
+ ZIPERR(ZE_PARMS, "password verification failed");
+ }
++#endif
+ }
+ if (key) {
+ /* if -P "" could get here */
+--- zipcloak.c
++++ zipcloak.c
+@@ -744,6 +744,28 @@ struct option_struct far options[] = {
+
+ int main OF((void));
+
++void zipmessage_nl(a, nl)
++ZCONST char *a;
++int nl;
++{
++}
++
++void zipmessage(a, b)
++ZCONST char *a, *b;
++{
++}
++
++int set_filetype(out_path)
++ char *out_path;
++{
++}
++
++int rename_split(temp_name, out_path)
++ char *temp_name;
++ char *out_path;
++{
++}
++
+ void zipwarn(msg1, msg2)
+ ZCONST char *msg1, *msg2;
+ {
diff --git a/app-arch/zip/zip-3.0.ebuild b/app-arch/zip/zip-3.0.ebuild
index 2854720226c1..3c98a5bb4d42 100644
--- a/app-arch/zip/zip-3.0.ebuild
+++ b/app-arch/zip/zip-3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-3.0.ebuild,v 1.1 2008/09/21 10:08:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-3.0.ebuild,v 1.2 2008/09/25 00:29:08 vapier Exp $
inherit toolchain-funcs eutils flag-o-matic
@@ -21,6 +21,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0-no-crypt.patch #238398
epatch "${FILESDIR}"/${PN}-3.0-pic.patch
epatch "${FILESDIR}"/${PN}-3.0-exec-stack.patch
epatch "${FILESDIR}"/${PN}-3.0-build.patch