summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-09-28 19:23:31 +0000
committerNed Ludd <solar@gentoo.org>2004-09-28 19:23:31 +0000
commit229db511b4bbb8934dba52b1599611808b784e82 (patch)
treebcbef4d26f5ee18893353b8135710e2f61b4ad80 /app-arch/zip
parentStable amd64. Added to ~sparc. (Manifest recommit) (diff)
downloadgentoo-2-229db511b4bbb8934dba52b1599611808b784e82.tar.gz
gentoo-2-229db511b4bbb8934dba52b1599611808b784e82.tar.bz2
gentoo-2-229db511b4bbb8934dba52b1599611808b784e82.zip
pie executables will have runtime text relocations in them with zip unless we disable the inline asm. This is done by adding a patch(tests via the pre compiler to see if we are generating pic code) to zips homegrown configure script. A better long term solution would be to fix said asm so pic users can get any speed advantages that may come from using inline asm.
Diffstat (limited to 'app-arch/zip')
-rw-r--r--app-arch/zip/ChangeLog12
-rw-r--r--app-arch/zip/Manifest5
-rw-r--r--app-arch/zip/files/digest-zip-2.3-r32
-rw-r--r--app-arch/zip/files/zip-2.3-unix_configure-pic.patch12
-rw-r--r--app-arch/zip/zip-2.3-r3.ebuild43
5 files changed, 72 insertions, 2 deletions
diff --git a/app-arch/zip/ChangeLog b/app-arch/zip/ChangeLog
index 67208fc3fca3..ec7b8402d3f9 100644
--- a/app-arch/zip/ChangeLog
+++ b/app-arch/zip/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-arch/zip
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.24 2004/07/20 20:03:11 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.25 2004/09/28 19:23:31 solar Exp $
+
+*zip-2.3-r3 (28 Sep 2004)
+
+ 28 Sep 2004; <solar@gentoo.org> +files/zip-2.3-unix_configure-pic.patch,
+ +zip-2.3-r3.ebuild:
+ pie executables will have runtime text relocations in them with zip unless we
+ disable the inline asm. This is done by adding a patch(tests via the pre
+ compiler to see if we are generating pic code) to zips homegrown configure
+ script. A better long term solution would be to fix said asm so pic users can
+ get any speed advantages that may come from using inline asm.
20 Jul 2004; Tom Gall <tgall@gentoo.org> zip-2.3-r2.ebuild:
stable on ppc64, bug #57660
diff --git a/app-arch/zip/Manifest b/app-arch/zip/Manifest
index fb9d5116054b..23dd3f70c317 100644
--- a/app-arch/zip/Manifest
+++ b/app-arch/zip/Manifest
@@ -1,5 +1,8 @@
-MD5 f3cfbe3281bc0fe3f9aca06b30d9c0d2 ChangeLog 2492
MD5 80d480950cc29fc888a316a430dfd72b zip-2.3-r1.ebuild 746
+MD5 3687deed5c97c60eff074f4b15fb02aa zip-2.3-r3.ebuild 1048
MD5 bba1a25568c491eb25562c8846b022fd zip-2.3-r2.ebuild 970
+MD5 1f8f7b09f4222afca26a60c4310e11e8 ChangeLog 2993
+MD5 6cf67950f3003a17d048c9a3ce4f243a files/zip-2.3-unix_configure-pic.patch 444
MD5 446598b124c5aa6073e4a431a166cc2d files/digest-zip-2.3-r1 57
MD5 0fae982a1638aacea39c862dd7ebbea6 files/digest-zip-2.3-r2 113
+MD5 0fae982a1638aacea39c862dd7ebbea6 files/digest-zip-2.3-r3 113
diff --git a/app-arch/zip/files/digest-zip-2.3-r3 b/app-arch/zip/files/digest-zip-2.3-r3
new file mode 100644
index 000000000000..09d293f79547
--- /dev/null
+++ b/app-arch/zip/files/digest-zip-2.3-r3
@@ -0,0 +1,2 @@
+MD5 5206a99541f3b0ab90f1baa167392c4f zip23.tar.gz 723283
+MD5 0c969ba1661183b041a142945ed2710e zcrypt29.zip 20248
diff --git a/app-arch/zip/files/zip-2.3-unix_configure-pic.patch b/app-arch/zip/files/zip-2.3-unix_configure-pic.patch
new file mode 100644
index 000000000000..45b137b0ed85
--- /dev/null
+++ b/app-arch/zip/files/zip-2.3-unix_configure-pic.patch
@@ -0,0 +1,12 @@
+--- unix/configure.orig 2004-09-28 06:45:33.000000000 +0000
++++ unix/configure 2004-09-28 06:54:53.000000000 +0000
+@@ -29,6 +29,9 @@
+
+ echo Check if we can use asm code
+ OBJA=""
++piclib="$(echo | $CPP -dM $CFLAGS - | grep -i __pic__)"
++echo "Checking if compiler wants to create pic code"
++[ "$piclib" == "" ] && \
+ if eval "$CPP match.S > _match.s 2>/dev/null"; then
+ if test ! -s _match.s || grep error < _match.s > /dev/null; then
+ :
diff --git a/app-arch/zip/zip-2.3-r3.ebuild b/app-arch/zip/zip-2.3-r3.ebuild
new file mode 100644
index 000000000000..2f09a00065a4
--- /dev/null
+++ b/app-arch/zip/zip-2.3-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.3-r3.ebuild,v 1.1 2004/09/28 19:23:31 solar Exp $
+
+inherit gcc eutils
+
+DESCRIPTION="Info ZIP (encryption support)"
+HOMEPAGE="ftp://ftp.freesoftware.com/pub/infozip/Zip.html"
+SRC_URI="mirror://gentoo/${PN}${PV/./}.tar.gz
+ crypt? ( ftp://ftp.icce.rug.nl/infozip/src/zcrypt29.zip )"
+
+LICENSE="Info-ZIP"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ia64 ~hppa ~mips ~ppc64"
+IUSE="crypt"
+
+DEPEND="crypt? ( app-arch/unzip )"
+
+src_unpack() {
+ unpack ${A}
+ if use crypt; then
+ mv -f crypt.h ${S}
+ mv -f crypt.c ${S}
+ fi
+ cd ${S}
+ epatch ${FILESDIR}/zip-2.3-unix_configure-pic.patch
+ cd ${S}/unix
+ sed -i -e "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake \
+ -f unix/Makefile \
+ CC="$(gcc-getCC)" \
+ CPP="$(gcc-getCC) -E" \
+ generic || die
+}
+
+src_install() {
+ dobin zip zipcloak zipnote zipsplit
+ doman man/zip.1
+ dodoc BUGS CHANGES LICENSE MANUAL README TODO WHATSNEW WHERE
+}