summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-23 18:27:00 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-23 18:27:00 +0000
commitef992b46f333355e551dece45a1d2579820eb84d (patch)
treeedd3e79d1f4ebb839fcd43a1e293d7fdac093acd /app-arch/xz-utils
parentFix embryo dependency (diff)
downloadgentoo-2-ef992b46f333355e551dece45a1d2579820eb84d.tar.gz
gentoo-2-ef992b46f333355e551dece45a1d2579820eb84d.tar.bz2
gentoo-2-ef992b46f333355e551dece45a1d2579820eb84d.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/xz-utils')
-rw-r--r--app-arch/xz-utils/ChangeLog8
-rw-r--r--app-arch/xz-utils/xz-utils-5.0.4.ebuild67
2 files changed, 73 insertions, 2 deletions
diff --git a/app-arch/xz-utils/ChangeLog b/app-arch/xz-utils/ChangeLog
index eed42e3c50af..1e935dc7f57d 100644
--- a/app-arch/xz-utils/ChangeLog
+++ b/app-arch/xz-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/xz-utils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.43 2012/05/17 04:05:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.44 2012/06/23 18:27:00 vapier Exp $
+
+*xz-utils-5.0.4 (23 Jun 2012)
+
+ 23 Jun 2012; Mike Frysinger <vapier@gentoo.org> +xz-utils-5.0.4.ebuild:
+ Version bump.
17 May 2012; Mike Frysinger <vapier@gentoo.org> xz-utils-5.0.3.ebuild,
xz-utils-9999.ebuild:
@@ -165,4 +170,3 @@
07 Feb 2009; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+xz-utils-9999.ebuild:
Initial ebuild by me.
-
diff --git a/app-arch/xz-utils/xz-utils-5.0.4.ebuild b/app-arch/xz-utils/xz-utils-5.0.4.ebuild
new file mode 100644
index 000000000000..9afde9b98127
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-5.0.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-5.0.4.ebuild,v 1.1 2012/06/23 18:27:00 vapier Exp $
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://git.tukaani.org/xz.git"
+ inherit git-2 autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+ EXTRA_DEPEND=
+fi
+
+inherit eutils multilib
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="http://tukaani.org/xz/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="nls static-libs +threads"
+
+RDEPEND="!<app-arch/lzma-4.63
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+src_prepare() {
+ eautopoint
+ eautoreconf
+}
+fi
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}"/usr/ -name liblzma.la -delete || die # dependency_libs=''
+ rm "${D}"/usr/share/doc/xz/COPYING* || die
+ mv "${D}"/usr/share/doc/{xz,${PF}} || die
+ prepalldocs
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/liblzma.so.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/liblzma.so.0
+}