summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-07 20:32:22 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-07 20:32:22 +0000
commitddb422f87bd847fe6e4bd2a49856578ee740f1e0 (patch)
tree18da34fee1f1c893700ab98d5473379ca8170912 /app-arch/xz-utils/xz-utils-9999.ebuild
parentFixed pre-stripped files issue ( see bug #255937 ) (diff)
downloadgentoo-2-ddb422f87bd847fe6e4bd2a49856578ee740f1e0.tar.gz
gentoo-2-ddb422f87bd847fe6e4bd2a49856578ee740f1e0.tar.bz2
gentoo-2-ddb422f87bd847fe6e4bd2a49856578ee740f1e0.zip
Initial ebuild by me.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/xz-utils/xz-utils-9999.ebuild')
-rw-r--r--app-arch/xz-utils/xz-utils-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-arch/xz-utils/xz-utils-9999.ebuild b/app-arch/xz-utils/xz-utils-9999.ebuild
new file mode 100644
index 000000000000..7337319e661b
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-9999.ebuild,v 1.1 2009/02/07 20:32:22 vapier Exp $
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://ctrl.tukaani.org/xz.git"
+ inherit git autotools
+ SRC_URI=""
+else
+ SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+fi
+
+inherit eutils
+
+MY_P="${PN}-${PV/_}"
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="http://tukaani.org/xz/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!app-arch/lzma
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+ else
+ unpack ${A}
+ cd "${S}"
+ fi
+}
+
+src_compile() {
+ econf --enable-dynamic || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}