summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2007-01-07 11:55:59 +0000
committerHarald van Dijk <truedfx@gentoo.org>2007-01-07 11:55:59 +0000
commitd4f99eb3955da80abd11056379ee05592f00140d (patch)
tree0b4841d72c1bd4acaa88d8901908251c194d8719 /app-arch/unzip
parentarm/sh stable (diff)
downloadgentoo-2-d4f99eb3955da80abd11056379ee05592f00140d.tar.gz
gentoo-2-d4f99eb3955da80abd11056379ee05592f00140d.tar.bz2
gentoo-2-d4f99eb3955da80abd11056379ee05592f00140d.zip
Handle NetBSD CHOST and properly check for x86 for other BSDs
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'app-arch/unzip')
-rw-r--r--app-arch/unzip/ChangeLog7
-rw-r--r--app-arch/unzip/unzip-5.52-r1.ebuild11
2 files changed, 11 insertions, 7 deletions
diff --git a/app-arch/unzip/ChangeLog b/app-arch/unzip/ChangeLog
index afda1b1fc6f7..2170f0ba518c 100644
--- a/app-arch/unzip/ChangeLog
+++ b/app-arch/unzip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/unzip
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/ChangeLog,v 1.46 2006/10/24 09:55:15 uberlord Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/ChangeLog,v 1.47 2007/01/07 11:55:59 truedfx Exp $
+
+ 07 Jan 2007; Harald van Dijk <truedfx@gentoo.org> unzip-5.52-r1.ebuild:
+ Handle NetBSD CHOST and properly check for x86 for other BSDs
24 Oct 2006; Roy Marples <uberlord@gentoo.org> unzip-5.52-r1.ebuild:
Don't assume that freebsd == i386 :)
diff --git a/app-arch/unzip/unzip-5.52-r1.ebuild b/app-arch/unzip/unzip-5.52-r1.ebuild
index 23afa78afc50..fe123cf64e0e 100644
--- a/app-arch/unzip/unzip-5.52-r1.ebuild
+++ b/app-arch/unzip/unzip-5.52-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.17 2006/10/24 09:55:15 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.18 2007/01/07 11:55:59 truedfx Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -37,9 +37,10 @@ src_compile() {
case ${CHOST} in
i?86*-linux*) TARGET=linux_asm ;;
*-linux*) TARGET=linux_noasm ;;
- *-dragonfly*) use x86 && TARGET=freebsd || TARGET=bsd ;;
- *-freebsd*) use x86 && TARGET=freebsd || TARGET=bsd ;;
- *-openbsd*) TARGET=bsd ;;
+ i?86*-freebsd* | i?86*-dragonfly* | i?86*-openbsd* | i?86*-netbsd*)
+ TARGET=freebsd ;; # mislabelled bsd with x86 asm
+ *-freebsd* | *-dragonfly* | *-openbsd* | *-netbsd*)
+ TARGET=bsd ;;
*-darwin*) TARGET=macosx ;;
*) die "Unknown target, you suck" ;;
esac