summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-05-26 23:41:12 +0000
committerMatthias Maier <tamiko@gentoo.org>2015-05-26 23:41:12 +0000
commita58956b742ab5011dbb286b6d92ad5532198e4e5 (patch)
tree927811d742d614c6ca683e511980285e5bfba551 /app-arch/tarsync
parentdrop maintainership (diff)
downloadgentoo-2-a58956b742ab5011dbb286b6d92ad5532198e4e5.tar.gz
gentoo-2-a58956b742ab5011dbb286b6d92ad5532198e4e5.tar.bz2
gentoo-2-a58956b742ab5011dbb286b6d92ad5532198e4e5.zip
fix compilation with gcc-5.1, bug #548314
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'app-arch/tarsync')
-rw-r--r--app-arch/tarsync/ChangeLog8
-rw-r--r--app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch59
-rw-r--r--app-arch/tarsync/tarsync-0.2.1-r1.ebuild5
3 files changed, 68 insertions, 4 deletions
diff --git a/app-arch/tarsync/ChangeLog b/app-arch/tarsync/ChangeLog
index aa8276ffa478..912ada13c887 100644
--- a/app-arch/tarsync/ChangeLog
+++ b/app-arch/tarsync/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/tarsync
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tarsync/ChangeLog,v 1.23 2014/01/26 22:38:39 ottxor Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tarsync/ChangeLog,v 1.24 2015/05/26 23:41:12 tamiko Exp $
+
+ 26 May 2015; Matthias Maier <tamiko@gentoo.org>
+ +files/tarsync-0.2.1-gcc5.patch, tarsync-0.2.1-r1.ebuild:
+ fix compilation with gcc-5.1, bug #548314
26 Jan 2014; Christoph Junghans <ottxor@gentoo.org> tarsync-0.2.1-r1.ebuild:
added prefix support
diff --git a/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch b/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch
new file mode 100644
index 000000000000..f11c86bb248a
--- /dev/null
+++ b/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch
@@ -0,0 +1,59 @@
+diff --git a/excludes.c b/excludes.c
+index b7c928d..fa43cef 100644
+--- a/excludes.c
++++ b/excludes.c
+@@ -106,7 +106,7 @@ build_exclude(fnm_exclude **ex_ptr, const char *pattern)
+ }
+
+
+-inline int
++int
+ match_excludes(const char *dir, const char *file, fnm_exclude **excludes)
+ {
+ char *p;
+diff --git a/main.c b/main.c
+index 84feed4..2c2da3e 100644
+--- a/main.c
++++ b/main.c
+@@ -42,8 +42,8 @@ int remove_node(const char *path, struct stat *st);
+ int ensure_files_layout(const tar_entry **ttar, const unsigned int ttar_count, tar_entry ***missing,
+ unsigned int *missing_count, tar_entry ***existing, unsigned int *existing_count,
+ fnm_exclude **excludes);
+-inline int check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st);
+-inline int enforce_owner(const char *path, const tar_entry *t, struct stat *st);
++int check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st);
++int enforce_owner(const char *path, const tar_entry *t, struct stat *st);
+ int copy_whole_file(cfile *tar_cfh, const tar_entry *ttent);
+
+ static int check_mtime = 1;
+@@ -669,7 +669,7 @@ recursively_delete_dir(const char *path)
+ return ret;
+ }
+
+-inline int
++int
+ check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st)
+ {
+ int type;
+@@ -685,7 +685,7 @@ check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st
+ return 0;
+ }
+
+-inline int
++int
+ enforce_owner(const char *path, const tar_entry *t, struct stat *st)
+ {
+ struct stat st2;
+diff --git a/tar.c b/tar.c
+index 792ccd4..42dc8e7 100644
+--- a/tar.c
++++ b/tar.c
+@@ -40,7 +40,7 @@ int check_str_chksum(const char *block)
+
+ /* possibly this could be done different, what of endptr of strtol?
+ Frankly I worry about strtol trying to go too far and causing a segfault, due to tar fields not always having trailing \0 */
+-inline unsigned long octal_str2long(const char *string, unsigned int length)
++unsigned long octal_str2long(const char *string, unsigned int length)
+ {
+ if(string[length]) {
+ char *ptr = strndup(string, length);
diff --git a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
index bca45bd78b0d..7a86ffb41f55 100644
--- a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
+++ b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tarsync/tarsync-0.2.1-r1.ebuild,v 1.7 2014/01/26 22:38:39 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tarsync/tarsync-0.2.1-r1.ebuild,v 1.8 2015/05/26 23:41:12 tamiko Exp $
EAPI=5
@@ -26,6 +26,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-gcc5.patch
}
src_install() {