summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-22 22:14:55 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-22 22:14:55 +0000
commit3443893fdd1dcd8ad287b8a02ff79393a7aea748 (patch)
tree6bbdfc90d7e6acb9c338c7c36bc9a4563d13a289 /app-arch/tar
parentInitial import (diff)
downloadgentoo-2-3443893fdd1dcd8ad287b8a02ff79393a7aea748.tar.gz
gentoo-2-3443893fdd1dcd8ad287b8a02ff79393a7aea748.tar.bz2
gentoo-2-3443893fdd1dcd8ad287b8a02ff79393a7aea748.zip
Fix building with glibc-2.16+.
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/ChangeLog6
-rw-r--r--app-arch/tar/files/tar-1.26-no-gets.patch22
-rw-r--r--app-arch/tar/tar-1.26-r1.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/app-arch/tar/ChangeLog b/app-arch/tar/ChangeLog
index a0180637856f..c160511deb82 100644
--- a/app-arch/tar/ChangeLog
+++ b/app-arch/tar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/tar
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.172 2012/03/19 19:02:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.173 2012/05/22 22:14:55 vapier Exp $
+
+ 22 May 2012; Mike Frysinger <vapier@gentoo.org> tar-1.26-r1.ebuild,
+ +files/tar-1.26-no-gets.patch:
+ Fix building with glibc-2.16+.
19 Mar 2012; Raúl Porcel <armin76@gentoo.org> tar-1.26.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #358749
diff --git a/app-arch/tar/files/tar-1.26-no-gets.patch b/app-arch/tar/files/tar-1.26-no-gets.patch
new file mode 100644
index 000000000000..a677af11d370
--- /dev/null
+++ b/app-arch/tar/files/tar-1.26-no-gets.patch
@@ -0,0 +1,22 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/gnu/stdio.in.h
++++ b/gnu/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/app-arch/tar/tar-1.26-r1.ebuild b/app-arch/tar/tar-1.26-r1.ebuild
index 03d30856defb..528914f50790 100644
--- a/app-arch/tar/tar-1.26-r1.ebuild
+++ b/app-arch/tar/tar-1.26-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.26-r1.ebuild,v 1.2 2012/03/04 15:35:15 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.26-r1.ebuild,v 1.3 2012/05/22 22:14:55 vapier Exp $
EAPI="3"
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-xattr.patch #382067
+ epatch "${FILESDIR}"/${P}-no-gets.patch
eautoreconf
if ! use userland_GNU ; then