summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-03-04 16:05:49 +0000
committerPeter Volkov <pva@gentoo.org>2008-03-04 16:05:49 +0000
commita2708bf5f9e43bd92a28cd0fb18652b71b7484d4 (patch)
treed9fd0ce37631dee8d1b6ff4a95b2c7b393870c29 /app-arch/star
parentRemoved mask for loki_patch, since that version has been removed from the tree. (diff)
downloadgentoo-2-a2708bf5f9e43bd92a28cd0fb18652b71b7484d4.tar.gz
gentoo-2-a2708bf5f9e43bd92a28cd0fb18652b71b7484d4.tar.bz2
gentoo-2-a2708bf5f9e43bd92a28cd0fb18652b71b7484d4.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-arch/star')
-rw-r--r--app-arch/star/ChangeLog7
-rw-r--r--app-arch/star/star-1.5_alpha88.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/app-arch/star/ChangeLog b/app-arch/star/ChangeLog
index 1aa2c814de3e..06ea1bb55389 100644
--- a/app-arch/star/ChangeLog
+++ b/app-arch/star/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/star
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/star/ChangeLog,v 1.63 2008/02/21 17:22:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/star/ChangeLog,v 1.64 2008/03/04 16:05:49 pva Exp $
+
+*star-1.5_alpha88 (04 Mar 2008)
+
+ 04 Mar 2008; <pva@gentoo.org> +star-1.5_alpha88.ebuild:
+ Version bump.
21 Feb 2008; Raúl Porcel <armin76@gentoo.org>
-files/star-1.5_alpha84-data-change-warn.patch, -star-1.5_alpha84.ebuild,
diff --git a/app-arch/star/star-1.5_alpha88.ebuild b/app-arch/star/star-1.5_alpha88.ebuild
new file mode 100644
index 000000000000..3837c8c05145
--- /dev/null
+++ b/app-arch/star/star-1.5_alpha88.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/star/star-1.5_alpha88.ebuild,v 1.1 2008/03/04 16:05:49 pva Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
+HOMEPAGE="http://cdrecord.berlios.de/old/private/star.html"
+SRC_URI="ftp://ftp.berlios.de/pub/${PN}/alpha/${PN}-${PV/_alpha/a}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P/_alpha[0-9][0-9]}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cd "${S}"/DEFAULTS
+ sed -i \
+ -e 's:/opt/schily:/usr:g' \
+ -e 's:bin:root:g' \
+ -e 's:/usr/src/linux/include:/usr/include:' \
+ Defaults.linux
+
+ if use amd64 ; then
+ cd "${S}"/RULES
+ cp i386-linux-cc.rul x86_64-linux-cc.rul
+ cp i386-linux-gcc.rul x86_64-linux-gcc.rul
+ fi
+
+ if use ppc64 ; then
+ cd "${S}"/RULES
+ cp ppc-linux-cc.rul ppc64-linux-cc.rul
+ cp ppc-linux-gcc.rul ppc64-linux-gcc.rul
+ fi
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" COPTX="${CFLAGS}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die
+}
+
+src_install() {
+ # Joerg Schilling suggested to integrate star into the main OS using call:
+ # make INS_BASE=/usr DESTDIR="${D}" install
+
+ dobin star/OBJ/*-*-cc/star || die "dobin star failed"
+ dobin tartest/OBJ/*-*-cc/tartest || die "dobin tartest failed"
+ dobin star_sym/OBJ/*-*-cc/star_sym || die "dobin star_sym failed"
+ dobin mt/OBJ/*-*-cc/smt || die "dobin smt failed"
+
+ newsbin rmt/OBJ/*-*-cc/rmt rmt.star
+ newman rmt/rmt.1 rmt.star.1
+
+ # Note that we should never install gnutar, tar or rmt in this package.
+ # tar and rmt are provided by app-arch/tar. gnutar is not compatible with
+ # GNU tar and breakes compilation, or init scripts. bug #33119
+ dosym /usr/bin/{star,ustar}
+ dosym /usr/bin/{star,spax}
+ dosym /usr/bin/{star,scpio}
+ dosym /usr/bin/{star,suntar}
+
+ # match is needed to understand the pattern matcher, if you wondered why ;)
+ mv star/{star.4,star.5}
+ doman man/man1/match.1 tartest/tartest.1 \
+ star/{star.5,star.1,spax.1,scpio.1,suntar.1}
+
+ insinto /etc/default
+ newins star/star.dfl star
+ newins rmt/rmt.dfl rmt
+
+ dodoc star/{README.ACL,README.crash,README.largefiles,README.otherbugs} \
+ star/{README.pattern,README.pax,README.posix-2001,README,STARvsGNUTAR} \
+ rmt/default-rmt.sample TODO AN-* Changelog CONTRIBUTING
+}