summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-26 06:13:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-26 06:13:42 +0000
commiteb98ec7b401cd4089168c252984975f8d4dcbd6e (patch)
treeece450f5277c7f0f7deca1f61d1679a4a43fc0f6 /app-arch/snappy
parentfixed dep on prettytable (bad interaction with quantumclient) (diff)
downloadgentoo-2-eb98ec7b401cd4089168c252984975f8d4dcbd6e.tar.gz
gentoo-2-eb98ec7b401cd4089168c252984975f8d4dcbd6e.tar.bz2
gentoo-2-eb98ec7b401cd4089168c252984975f8d4dcbd6e.zip
Bump for #457626
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-arch/snappy')
-rw-r--r--app-arch/snappy/ChangeLog7
-rw-r--r--app-arch/snappy/snappy-1.1.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-arch/snappy/ChangeLog b/app-arch/snappy/ChangeLog
index a6767a90b296..65d7df6b144d 100644
--- a/app-arch/snappy/ChangeLog
+++ b/app-arch/snappy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/snappy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/ChangeLog,v 1.4 2013/03/03 02:54:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/ChangeLog,v 1.5 2013/03/26 06:13:42 patrick Exp $
+
+*snappy-1.1.0 (26 Mar 2013)
+
+ 26 Mar 2013; Patrick Lauer <patrick@gentoo.org> +snappy-1.1.0.ebuild:
+ Bump for #457626
03 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> snappy-1.0.5.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/app-arch/snappy/snappy-1.1.0.ebuild b/app-arch/snappy/snappy-1.1.0.ebuild
new file mode 100644
index 000000000000..eb5ec283593b
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/snappy-1.1.0.ebuild,v 1.1 2013/03/26 06:13:42 patrick Exp $
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DOCS="AUTHORS ChangeLog README NEWS format_description.txt"
+
+src_prepare() {
+ default
+ # Avoid automagic lzop and gzip by not checking for it
+ sed -i -e '/^CHECK_EXT_COMPRESSION_LIB/d' "${S}/configure.ac" || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove docs installed by snappy itself
+ rm -rf "${ED}/usr/share/doc/snappy" || die
+
+ prune_libtool_files
+}