summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-17 09:49:35 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-17 09:49:35 +0000
commitde1eeba214dde948bf80b89c95f85a8c224c87b2 (patch)
treebb462eddfd6dec9ba58b3c391cc09eb5f2698a0b /app-arch/sharutils
parentVersion bump #237155 by Conrad Kostecki. (diff)
downloadgentoo-2-de1eeba214dde948bf80b89c95f85a8c224c87b2.tar.gz
gentoo-2-de1eeba214dde948bf80b89c95f85a8c224c87b2.tar.bz2
gentoo-2-de1eeba214dde948bf80b89c95f85a8c224c87b2.zip
Version bump #237151 by Conrad Kostecki.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'app-arch/sharutils')
-rw-r--r--app-arch/sharutils/ChangeLog9
-rw-r--r--app-arch/sharutils/sharutils-4.7.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/app-arch/sharutils/ChangeLog b/app-arch/sharutils/ChangeLog
index ad3014c107e6..7a2207853f4d 100644
--- a/app-arch/sharutils/ChangeLog
+++ b/app-arch/sharutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/sharutils
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/ChangeLog,v 1.53 2007/07/02 13:38:54 dragonheart Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/ChangeLog,v 1.54 2008/09/17 09:49:35 vapier Exp $
+
+*sharutils-4.7 (17 Sep 2008)
+
+ 17 Sep 2008; Mike Frysinger <vapier@gentoo.org> +sharutils-4.7.ebuild:
+ Version bump #237151 by Conrad Kostecki.
02 Jul 2007; Daniel Black <dragonheart@gentoo.org>
-files/sharutils-4.2.1-buffer-check.patch,
diff --git a/app-arch/sharutils/sharutils-4.7.ebuild b/app-arch/sharutils/sharutils-4.7.ebuild
new file mode 100644
index 000000000000..2ae6092f5d38
--- /dev/null
+++ b/app-arch/sharutils/sharutils-4.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/sharutils-4.7.ebuild,v 1.1 2008/09/17 09:49:35 vapier Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="Tools to deal with shar archives"
+HOMEPAGE="http://www.gnu.org/software/sharutils/"
+SRC_URI="mirror://gnu/${PN}/REL-${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="sys-apps/texinfo
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ strip-linguas -u po
+ econf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}