summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2006-02-20 08:56:22 +0000
committerBrian Harring <ferringb@gentoo.org>2006-02-20 08:56:22 +0000
commit6aca355b37daff5943ae11899ca2abe6da572a53 (patch)
tree80cb3f280ba18537925b3dc880c07bf645ce47ca /app-arch/rzip/rzip-2.1.ebuild
parentAdd src_test functionality. (diff)
downloadgentoo-2-6aca355b37daff5943ae11899ca2abe6da572a53.tar.gz
gentoo-2-6aca355b37daff5943ae11899ca2abe6da572a53.tar.bz2
gentoo-2-6aca355b37daff5943ae11899ca2abe6da572a53.zip
version bump, bug 123431
(Portage version: 2703-svn)
Diffstat (limited to 'app-arch/rzip/rzip-2.1.ebuild')
-rw-r--r--app-arch/rzip/rzip-2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/rzip/rzip-2.1.ebuild b/app-arch/rzip/rzip-2.1.ebuild
new file mode 100644
index 000000000000..edb785aa8e97
--- /dev/null
+++ b/app-arch/rzip/rzip-2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rzip/rzip-2.1.ebuild,v 1.1 2006/02/20 08:56:22 ferringb Exp $
+
+inherit autotools
+
+DESCRIPTION="compression program for large files"
+HOMEPAGE="http://rzip.samba.org/"
+SRC_URI="http://rzip.samba.org/ftp/rzip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/bzip2
+ >=sys-devel/autoconf-2.59"
+RDEPEND="app-arch/bzip2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.0-darwin.patch
+ WANT_AUTOCONF="2.5" eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "failed installing"
+}