summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-25 12:38:02 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-25 12:38:02 +0000
commitf677c340e307d548b9e0e9232e1f9f8922e9b60d (patch)
tree75cd2a19e2958007d19f1fb8ee1bfab10574238d /app-arch/rpm
parentNew version (Manifest recommit) (diff)
downloadgentoo-2-f677c340e307d548b9e0e9232e1f9f8922e9b60d.tar.gz
gentoo-2-f677c340e307d548b9e0e9232e1f9f8922e9b60d.tar.bz2
gentoo-2-f677c340e307d548b9e0e9232e1f9f8922e9b60d.zip
Using python eclass to choose python version, optimize/remove pyc/pyo, added py2.3 patch thanks to Vaclav Slavik <vaclav.slavik@matfyz.cz> (#39282)
Diffstat (limited to 'app-arch/rpm')
-rw-r--r--app-arch/rpm/ChangeLog7
-rw-r--r--app-arch/rpm/files/rpm-4.2-python2.3.diff44
-rw-r--r--app-arch/rpm/rpm-4.2.1.ebuild22
-rw-r--r--app-arch/rpm/rpm-4.2_pre069.ebuild4
4 files changed, 68 insertions, 9 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index f1a60fe3c610..b9f2d507814c 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/rpm
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.32 2004/01/15 19:59:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.33 2004/01/25 12:38:02 liquidx Exp $
+
+ 25 Jan 2004; Alastair Tse <liquidx@gentoo.org> rpm-4.2.1.ebuild,
+ files/rpm-4.2-python2.3.diff:
+ Using python eclass to choose python version, optimize/remove pyc/pyo, added
+ py2.3 patch thanks to Vaclav Slavik <vaclav.slavik@matfyz.cz> (#39282)
15 Jan 2004; <agriffis@gentoo.org> rpm-4.2.1.ebuild:
stable on alpha and ia64
diff --git a/app-arch/rpm/files/rpm-4.2-python2.3.diff b/app-arch/rpm/files/rpm-4.2-python2.3.diff
new file mode 100644
index 000000000000..6326c0d37832
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.2-python2.3.diff
@@ -0,0 +1,44 @@
+diff -ru rpm-4.2.1/python/Makefile.in rpm-4.2.1.new/python/Makefile.in
+--- rpm-4.2.1/python/Makefile.in 2003-07-16 19:05:47.000000000 +0200
++++ rpm-4.2.1.new/python/Makefile.in 2004-01-24 21:38:59.000000000 +0100
+@@ -258,7 +258,8 @@
+
+ PYVER = @WITH_PYTHON_VERSION@
+
+-pylibdir = $(shell python -c 'import sys; print sys.path[1]')
++
++pythondir = $(shell python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1,0)')
+ pyincdir = $(prefix)/include/python${PYVER}
+
+ SUBDIRS = rpmdb test
+@@ -291,10 +292,9 @@
+
+ LDADD =
+
+-pythondir = $(pylibdir)/site-packages
+ python_PROGRAMS = rpmmodule.so
+
+-rpmdbdir = $(pylibdir)/site-packages/rpmdb
++rpmdbdir = $(pythondir)/rpmdb
+ rpmdb_PROGRAMS = _rpmdb.so
+
+ noinst_PROGRAMS = poptmodule.so
+diff -ru rpm-4.2.1/python/rpmdb/Makefile.in rpm-4.2.1.new/python/rpmdb/Makefile.in
+--- rpm-4.2.1/python/rpmdb/Makefile.in 2003-07-16 19:05:47.000000000 +0200
++++ rpm-4.2.1.new/python/rpmdb/Makefile.in 2004-01-24 22:06:07.000000000 +0100
+@@ -256,13 +256,13 @@
+
+ PYVER = @WITH_PYTHON_VERSION@
+
+-pylibdir = $(shell python -c 'import sys; print sys.path[1]')
++pythondir = $(shell python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1,0)')
+
+ EXTRA_DIST = \
+ __init__.py dbobj.py db.py dbrecio.py dbshelve.py dbtables.py dbutils.py
+
+
+-rpmdbdir = $(pylibdir)/site-packages/rpmdb
++rpmdbdir = $(pythondir)/rpmdb
+ rpmdb_SCRIPTS = \
+ __init__.py dbobj.py db.py dbrecio.py dbshelve.py dbtables.py dbutils.py
+
diff --git a/app-arch/rpm/rpm-4.2.1.ebuild b/app-arch/rpm/rpm-4.2.1.ebuild
index dd2ca6fc4d23..8f6fd058cc7d 100644
--- a/app-arch/rpm/rpm-4.2.1.ebuild
+++ b/app-arch/rpm/rpm-4.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.2.1.ebuild,v 1.9 2004/01/15 19:59:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.2.1.ebuild,v 1.10 2004/01/25 12:38:02 liquidx Exp $
-inherit flag-o-matic libtool eutils
+inherit python flag-o-matic libtool eutils
DESCRIPTION="Red Hat Package Management Utils"
SRC_URI="mirror://gentoo/rpm-4.2.1.tar.gz"
@@ -19,14 +19,14 @@ RDEPEND="=sys-libs/db-3.2*
dev-libs/elfutils
>=dev-libs/beecrypt-3.1.0-r1
nls? ( sys-devel/gettext )
- python? ( =dev-lang/python-2.2* )
- doc? ( app-doc/doxygen )"
-S=${WORKDIR}/rpm-4.2.1
+ python? ( >=dev-lang/python-2.2 )
+ !ia64? ( doc? ( app-doc/doxygen ) )"
strip-flags
src_unpack() {
unpack ${A}
+ epatch ${FILESDIR}/rpm-4.2-python2.3.diff
}
src_compile() {
@@ -35,8 +35,10 @@ src_compile() {
unset LD_ASSUME_KERNEL
local myconf
myconf="--enable-posixmutexes --without-javaglue"
+
+ python_version
use python \
- && myconf="${myconf} --with-python=2.2" \
+ && myconf="${myconf} --with-python=${PYVER}" \
|| myconf="${myconf} --without-python"
econf ${myconf} `use_enable nls` || die
@@ -81,4 +83,12 @@ pkg_postinst() {
einfo "No RPM database found... Creating database..."
${ROOT}/usr/bin/rpm --initdb --root=${ROOT}
fi
+
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/rpmdb
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
}
diff --git a/app-arch/rpm/rpm-4.2_pre069.ebuild b/app-arch/rpm/rpm-4.2_pre069.ebuild
index bf9a5e6a5471..bcd4b3ef19a7 100644
--- a/app-arch/rpm/rpm-4.2_pre069.ebuild
+++ b/app-arch/rpm/rpm-4.2_pre069.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.2_pre069.ebuild,v 1.6 2003/11/14 20:00:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.2_pre069.ebuild,v 1.7 2004/01/25 12:38:02 liquidx Exp $
inherit flag-o-matic libtool eutils
@@ -21,7 +21,7 @@ RDEPEND="=sys-libs/db-3.2*
dev-libs/elfutils
nls? ( sys-devel/gettext )
python? ( =dev-lang/python-2.2* )
- doc? ( app-doc/doxygen )"
+ !sparc? ( doc? ( app-doc/doxygen ) )"
S=${WORKDIR}/rpm-4.2
strip-flags